VirtualBox

Ticket #2956 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Cannot start Virtualbox as root user

Reported by: stevie_davies Owned by:
Priority: minor Component: host support
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Using 2.0.6 I could start Virtualbox as root user. After upgrading to 2.1.0 when I try and run Virtualbox I get the following message:

No protocol specified Qt WARNING: VirtualBox: cannot connect to X server :0.0

Am logged into Gnome with terminal open with local console. Am using "sudo -i" to gain root privilige.

All works OK as standard user, just not root.

Change History

comment:1 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

You should never start VirtualBox as root and there is no need to do so. Apart from this, the problem is the X authorization. Try to start an xterm the same way, it will fail as well. To be able to execute X applications as root you will need to copy the ~/.Xauthority file from the current user to the /root directory.

comment:2 Changed 5 years ago by bbock

  • Status changed from closed to reopened
  • Resolution invalid deleted

Same problem here on Ubuntu Intrepid 32bit.

X authorization is part the problem. But it seems to be more complex.

The strange thing is: xterm works perfectly fine, VBox not. Copying the .Xauthority file does not help. Also, all other X/QT apps except VBox work.

Workaround is issuing the command "xhost +localhost". This disables X authorization for all users on localhost. Then Vbox starts fine as user root.

The setup was working with VB 2.0.6 without disabling X authorization.

comment:3 Changed 5 years ago by frank

  • Priority changed from major to minor

Anyway, running VBox as root was never supported and probably will never be supported. That does not mean that we wouldn't make it work. So far I've no idea where the problem is.

comment:4 Changed 5 years ago by frank

  • Component changed from other to host support

comment:5 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

IIRC we fixed this issue in 2.1.2 or 2.1.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use