VirtualBox

Ticket #2929 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

BSOD on XP caused by VBoxNetFlt.sys driver => fixed in SVN

Reported by: dori Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

*

  • *
  • Bugcheck Analysis *
  • *

*

DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1) An attempt was made to access a pageable (or completely invalid) address at an interrupt request level (IRQL) that is too high. This is usually caused by drivers using improper addresses. If kernel debugger is available get stack backtrace. Arguments: Arg1: 00000000, memory referenced Arg2: 00000002, IRQL Arg3: 00000001, value 0 = read operation, 1 = write operation Arg4: b6c75193, address which referenced memory

Debugging Details:


WRITE_ADDRESS: 00000000

CURRENT_IRQL: 2

FAULTING_IP: VBoxNetFlt+4193 b6c75193 8902 mov dword ptr [edx],eax

DEFAULT_BUCKET_ID: DRIVER_FAULT

BUGCHECK_STR: 0xD1

PROCESS_NAME: System

TRAP_FRAME: 9f62fc88 -- (.trap 0xffffffff9f62fc88) ErrCode = 00000002 eax=00000000 ebx=00000000 ecx=89bc1160 edx=00000000 esi=89570414 edi=89570434 eip=b6c75193 esp=9f62fcfc ebp=9f62fd08 iopl=0 nv up ei ng nz ac pe cy cs=0008 ss=0010 ds=0023 es=0023 fs=0030 gs=0000 efl=00010297 VBoxNetFlt+0x4193: b6c75193 8902 mov dword ptr [edx],eax ds:0023:00000000=???????? Resetting default scope

LAST_CONTROL_TRANSFER: from b6c75193 to 805446f0

STACK_TEXT: 9f62fc88 b6c75193 badb0d00 00000000 b705f841 ntKiTrap0E+0x238 WARNING: Stack unwind information not available. Following frames may be wrong. 9f62fd08 b9c2012a 89570414 89570434 c00000bb VBoxNetFlt+0x4193 9f62fd30 b9c20362 89570434 895702e0 89bc1130 NDIS!ndisMSyncQueryInformationCompl ete+0x15e 9f62fd58 b9c1ca11 895702e0 89bc1130 89570434 NDIS!ndisMDoRequests+0x30c 9f62fd74 b9c203a6 895702e0 89570434 82c2d2a0 NDIS!ndisMRequest+0xfc 9f62fd98 b9c0dbaa 82c2d288 00000000 829d9958 NDIS!ndisMRundownRequests+0x32 9f62fdac 805cff70 82c2d290 00000000 00000000 NDIS!ndisWorkerThread+0x75 9f62fddc 805460ee b9c0db85 82c2d290 00000000 ntPspSystemThreadStartup+0x34 00000000 00000000 00000000 00000000 00000000 ntKiThreadStartup+0x16

STACK_COMMAND: kb

FOLLOWUP_IP: VBoxNetFlt+4193 b6c75193 8902 mov dword ptr [edx],eax

SYMBOL_STACK_INDEX: 1

SYMBOL_NAME: VBoxNetFlt+4193

FOLLOWUP_NAME: MachineOwner

MODULE_NAME: VBoxNetFlt

IMAGE_NAME: VBoxNetFlt.sys

DEBUG_FLR_IMAGE_TIMESTAMP: 4948ccb9

FAILURE_BUCKET_ID: 0xD1_W_VBoxNetFlt+4193

BUCKET_ID: 0xD1_W_VBoxNetFlt+4193

Followup: MachineOwner

Change History

comment:1 Changed 5 years ago by sandervl73

Please check defect #2937 for a test build that should fix the problem.

comment:2 Changed 5 years ago by misha

could you attach the minidump with a crash?

comment:3 Changed 5 years ago by frank

  • Component changed from network to network/hostif

comment:4 Changed 5 years ago by misha

  • Summary changed from BSOD on XP caused by VBoxNetFlt.sys driver to BSOD on XP caused by VBoxNetFlt.sys driver => fixed in SVN

no need for the crash dump, should be fixed in SVN now

comment:5 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use