VirtualBox

Ticket #2915 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

XP SP2 Host full networking failure with VB2.1

Reported by: kai+virtualbox Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 2.1.0 Keywords: network breaks hard
Cc: Guest type: other
Host type: Windows

Description

After upgrading from VB 2.0.6 to 2.1.0 on my host, all networking functions on my laptop started to fail. Uninstall had no effect, I had to do a Windows Restore Rollback to restore the machine to working order.

Thinkpad X31 (JUU2884 model), Win XP SP2, 1GB RAM Cisco VPN adapter Hamachi VPN adapter OpenVPN client installed, but not enabled AVG Anti-Virus 8.0.176 Comodo Firewall 3.5.x Bridging interface present, but was disabled, members had been removed Bridging was enabled under V2.06, but did not function - rolled back to NAT IBM Thinkvantage Access Connections managing wireless+wired adapters in system Wireless: 802.11A+B (Atheros AR5001X) Mini-PCI card (factory stock) Ethernet: Intel Pro/1000 MT Mobile (motherboard/stock)

After upgrading to VB2.1, the ThinkVantage app was unable to control the networking adapters in any shape or form - they could be enabled by key-combo *prior* to OS boot, but would not gain connectivity. Machine would turn mostly catatonic for minutes, as Win XP (and Thinkvantage) seemed to desperately try to get something out of the networking adapters.

Uninstall of VB2.1 had no effect. Re-install of VB2.06 had no effect. Rollback performed - restored functionality

Above steps repeated, and issue is 100% reproducible.

Change History

comment:1 Changed 5 years ago by frank

  • Component changed from network to network/hostif

comment:2 in reply to: ↑ description Changed 5 years ago by misha

Replying to kai+virtualbox:
I'm unable to reproduce the issue, however we've made some significant fixes to the installation that should probably fix your issue.
I can share with you a test build containing the fixes. Please send me a mail at Mikhail dot Sennikovsky at sun dot com if you're willing to test it. I'll then send you a link to a test version containing a fix.

comment:3 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 3.1.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use