VirtualBox

Ticket #2870 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

No Update Behind Proxy

Reported by: rwbenton Owned by:
Priority: minor Component: host support
Version: VirtualBox 3.0.8 Keywords: Proxy
Cc: Guest type: Linux
Host type: Windows

Description

The VB GUI attempts to both register and update while behind the corporate proxy. IE and Firefox are both configured with the proxy. Either grab the information from them or allow the user to add this information within the settings somewhere.

Attachments

VirtualBox-18022009_144825.jpg Download (24.1 KB) - added by rpetrequin 5 years ago.
Registration Error MessageBox
VirtualBox-18022009_144859.jpg Download (22.6 KB) - added by rpetrequin 5 years ago.
Update Error MessageBox

Change History

Changed 5 years ago by rpetrequin

Registration Error MessageBox

Changed 5 years ago by rpetrequin

Update Error MessageBox

comment:1 Changed 5 years ago by rpetrequin

I have the same problem with v2.1.4. I try with 2 different proxy Microsoft Proxy Server and Freeproxy, and it's the same. Do you have find more information?

comment:2 Changed 5 years ago by HelAu

Hello, This problem already exists in V3.0. Also the menu entry Hilfe->Webseite (German maybe help->webpage in english) does not work.

comment:3 Changed 5 years ago by mdeisher

The problem still exists in v3.0.8 r53138.

comment:4 Changed 5 years ago by sandervl73

  • Version changed from VirtualBox 2.0.6 to VirtualBox 3.0.8

comment:5 Changed 5 years ago by mattbishop

I can confirm this bug in OSX 10.5.8, VB3.0.4.

comment:6 in reply to: ↑ description Changed 4 years ago by rrmills

Problem still exists in 3.0.10.

comment:7 Changed 4 years ago by rojanu

The problem still persists in 3.1.0.

Is anybody looking at this ticket at all?

comment:8 Changed 4 years ago by pentagonik

I'll take a look at the problem.

comment:9 Changed 4 years ago by sandervl73

We'll look at it eventually, but there are many more important issues. Dismiss the dialog three times and it will not bother you again.

comment:10 Changed 4 years ago by aram_mm

Same problem here but with a strange twist to it. I actually managed to download the guest additions three days ago. Now neither guest additions nor updates can be downloaded because the connection times out.

comment:11 in reply to: ↑ description Changed 4 years ago by deesto

I'm seeing strange stuff here too, on OSX v3.1.2: using NAT to connect to my network (behind proxy) via wireless, a VH with Win Vista can get Win Updates, and IE can connect using "auto detect settings", but other applications (such as AVG Free 9 installer) fail to connect (even though AVG's install provides a dialog for proxy settings when a direct connect fails, the connection still fails after entering proxy info).

comment:12 follow-up: ↓ 13 Changed 4 years ago by dma_k

There is a demand of this options as well (v3.2.0). Especially when playing with test builds. Please, include also the option "Update only to stable builds". Proxy settings can be easily grabbed from IE (maybe there is a standard way to go via IE proxy in Windows?).

comment:13 in reply to: ↑ 12 Changed 3 years ago by bret.miller

We just had to implement a proxy server for PCI-DSS and same here--no update checking because it can't see the proxy server. Windows 64-bit.

comment:14 Changed 3 years ago by gtirloni

VirtualBox 4.0.8 here and corporate firewall policy mandates use of HTTP proxy. VB cannot update in this environment.

comment:15 Changed 3 years ago by Technologov

To all the whiners around here: Grab the newest 4.1.0_BETA and test Proxy.

 http://forums.virtualbox.org/viewforum.php?f=15

-Technologov

comment:16 Changed 3 years ago by deesto

I didn't realize that reporting bugs and describing issues on a bug tracker constituted as "whining", especially as this has been a long-standing issue through multiple releases. But anyway: thanks for the tip!

comment:17 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be finally implemented in 4.1.0.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use