VirtualBox

Ticket #2858 (closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

WindowsXP guest sound recording distorted when using pulseaudio interface

Reported by: mark_orion Owned by:
Priority: major Component: audio
Version: VirtualBox 2.0.6 Keywords: pulseaudio recording distortion
Cc: Guest type: Windows
Host type: other

Description

Audio recordings on a Windows guest are distorted when using the pulseaudio interface. The recording process is too slow so the resulting samples are high-pitched.

Attachments

30_seconds_pulseaudio.wav Download (366.2 KB) - added by sciurus 5 years ago.
30 seconds of audio recorded in winxp guest using pulseaudio on linux host

Change History

comment:1 Changed 5 years ago by mark_orion

The problems only occur when using the internal pulseaudio driver. A workaround is to use the ALSA driver with an ALSA configuration (.asoundrc) that uses the ALSA-pulseaudio plugin as default plugin.

comment:2 Changed 5 years ago by sciurus

I can confirm this with a Windows XP Professional SP2 running inside VirtualBox 3.0.0 on Fedora 11 64-bit. When I record 30 seconds of audio, the resulting file is 8 seconds long.

Changed 5 years ago by sciurus

30 seconds of audio recorded in winxp guest using pulseaudio on linux host

comment:3 Changed 4 years ago by crimsonflame123

I can confirm this VBox 3.08 , Fedora 11 host with pulseaudio and WinXP guest. Now all major distros are adopting PA... so this problem is only going to aggravate with time.

comment:4 Changed 4 years ago by crimsonflame123

I think this is a duplicate of  http://www.virtualbox.org/ticket/215.

Since pulseaudio recording works in SVN now, this ticket can be closed.

comment:5 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use