VirtualBox

Ticket #2820 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Debugger Detected

Reported by: damndebugger Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Windows
Host type: other

Description

There are lots of posts on the forum about this so you are all aware of it, but there doesn't seem to be a bug so:

Lots of software detects a debugger and tells you to unload it. Not just games, academic software too.

But if you want to test it out, just load any modern game or pick one of the many apps reported as a problem in the forum to try.

The VirtualBox main web page should mention this as it's a major problem for some people who waste hours setting up a system only to find they need to delete it and buy VMWare (!)

Hopefully it moves up the importance list a bit since it seems you've known about this for a long time. VirtualBox is amazing otherwise, for free you can't complain but it shouldn't have pretended it was fully mature software with such a major problem still present. I want my wasted hours back :)

Change History

comment:1 follow-up: ↓ 5 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

a) it's a duplicate b) it works for VT-x/AMD-V in 2.1.0 c) no need for sarcastic remarks

I want my wasted time back as well.

comment:2 Changed 5 years ago by damndebugger

a) Duplicate of which bug? b) Great, if you have a new expensive machine. It was cheaper and faster to buy VMWare which works without ticking a box for new processor extensions. I have just finished setting it all up and it works without a hitch. What is it VMWare does that VirtualBox doesn't that makes it more compatible with older hardware? Writing from an end-user perspective, apart from this incompatibility, VirtualBox is a more polished product. c) There wasn't any need for you to do it back, but it made you feel better. Yes, it was a foolish thing to write and I'm sorry.

The bug is re-openend because I don't know which bug it was a duplicate of. Since VMWare can do this and VirtualBox cannot - and there was no warning on the front page I stand by the statement that there should be a warning that VirtualBox isn't fully compatible with older hardware. This isn't meant to be antagonistic and I hope you consider it.

comment:3 Changed 5 years ago by frank

This bugtracker has a search function. Entering the search string 'debug' will give you some hits, you can turn off the hits from the Wiki and from changesets.

I don't think this is such a critical problem. Of course, everyone who is observing a bug has the opinion that his bug is the most important one and has to be clearly stated as such on the web pages and in the documentation. You might have noted that there are a lot of bugs open for VirtualBox and surely there are more critical ones than yours.

If your intension would be to help you had written a bug report with facts only. We are doing our work and working hard improving that software. And it seems to me that many people appreciate our work. You apparently don't. Statements like VMware can do this, so why can't VirtualBox the same? and I want to get my wasted time back don't improve my willingness to help.

comment:4 Changed 5 years ago by damndebugger

"I don't think this is such a critical problem.": Problem was set as major not critical.

"course, everyone who is observing a bug has the opinion that his bug is the most important one and has to be clearly stated as such on the web pages and in the documentation": I never stated that I thought this bug was the most important bug. The reason it deserves a warning on the front page is because putting on the front page that it does not work with software that detects debuggers such as a large amount of proprietary software would have saved a lot of my time for very little of yours, and I know from the forums I'm not alone in having VirtualBox be unsuitable due to this particular bug so it would have saved others time too.

"surely there are more critical": Bug was set as major not critical. For the minority it does effect it is effectively a blocker but as it's only a minority being affected then I knocked it down 2 levels. If you think it's just trivial OK, that's just a difference of opinion. I'm sure you have much better data on the number of people affected by this issue, but I think you will find considering how few people actually report a bug or even post to a forum when they have an issue with software the number may suprise you.

"If your intension would be to help you had written a bug report with facts only": If I'd intended only to help it would have contained facts only. The first report was intended to help, but also to antagonise as I was frustrated at how much time I'd lost, and I apologised for that in the second post. I'm not going to keep saying sorry for the same thing.

"Statements like VMware can do this, so why can't VirtualBox the same": I did not write that, just like I never said the bug was critical. I wrote "What is it VMWare does that VirtualBox doesn't that makes it more compatible with older hardware?" I wrote this because I thought if you thought about the difference that makes it work in VMWare, then the solution might come into your head. Not because I don't appreciate the work you have done but because I had realised you don't value this bug as important and therefore may not have thought about it.

For what it's worth I do appreciate the work you have done and I went to the trouble of running the application in VMWare, removing the debugger protection on the application and then switching back to VirtualBox because I prefer the product you have created.

Let's leave it at that?

comment:5 in reply to: ↑ 1 Changed 5 years ago by rmh

Replying to sandervl73:

b) it works for VT-x/AMD-V in 2.1.0

Hi,

If it works with VT-x/AMD-V, shouldn't these features be enabled by default whenever the CPU supports them?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use