VirtualBox

Ticket #2773 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

remoteDisplayInfo not active after starting VBoxHeadless machine => Fixed in SVN

Reported by: mjlucas Owned by:
Priority: critical Component: RDP
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: other
Host type: Linux

Description

After starting a VM with 2.1 VBoxHeadless the Virtual Display status cannot be queried through the API. The VRDP server is working, you can connect to it from a RDP client.

Linux artemis1 2.6.18-92.el5 #1 SMP Tue Apr 29 13:16:15 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux

[vmuser@artemis1 bin]$ VBoxHeadless -startvm 1035 -vrdp on
VirtualBox Headless Interface 2.1.0
(C) 2008 Sun Microsystems, Inc.
All rights reserved

Listening on port 3389
[vmuser@artemis1 ~]$ VBoxManage showvminfo 1035 -machinereadable
VirtualBox Command Line Management Interface Version 2.1.0
(C) 2005-2008 Sun Microsystems, Inc.
All rights reserved.

name="1035"
ostype="WindowsXP"
UUID="3594dd74-736e-4a6d-5a83-0b185d86ffc2"
CfgFile="/vmuser/vmachines/Machines/1035/1035.xml"
memory=512
vram=8
bootmenu="messageandmenu"
acpi="on"
ioapic="off"
pae="off"
biossystemtimeoffset=0
hwvirtex="off"
nestedpaging="off"
vtxvpid="off"
VMState="running"
VMStateChangeTime="2008-12-18T00:21:56.680000000"
monitorcount=1
accelerate3d="off"
floppy="empty"
sata="off"
idecontroller="PIIX3"
hda="/vmuser/vmachines/Machines/1035/1035.vdi"
HdaImageUUID="18a20fcc-c809-462d-8449-d408c7866bad"
hdb="none"
hdd="none"
dvd="none"
dvdpassthrough="off"
macaddress1="080027B61775"
cableconnected1="on"
nic1="null"
nic2="none"
nic3="none"
nic4="none"
nic5="none"
nic6="none"
nic7="none"
nic8="none"
uart1="off"
uart2="off"
audio="none"
clipboard="bidirectional"
VideoMode="1024,768,32"
vrdp="on"
vrdpport=3389
vrdpaddress=""
vrdpauthtype="external"
vrdpmulticon="off"
vrdpreusecon="off"
usb="off"
[!] FAILED calling remoteDisplayInfo->GetActive (&Active) at line 1511!
[!] Primary RC  = E_ACCESSDENIED (0x80070005) - Access denied
[!] Full error info present: true , basic error info present: true
[!] Result Code = E_ACCESSDENIED (0x80070005) - Access denied
[!] Text        = The object is not ready
[!] Component   = RemoteDisplayInfo, Interface: IRemoteDisplayInfo,
{550104cd-2dfd-4a6c-857d-f6f8e088e62c}
[!] Callee      = IRemoteDisplayInfo,
{550104cd-2dfd-4a6c-857d-f6f8e088e62c}

Change History

comment:1 Changed 5 years ago by mjlucas

Same thing happens when starting with VBoxManage startvm 1035 -type vrdp

comment:2 Changed 5 years ago by frank

Confirmed. Actually this happens if the VM is running in any mode, not even in headless mode.

comment:3 Changed 5 years ago by mjlucas

Once there is a fix, could you please send me a version to test? 2.1 in our test/development environment has broken all of our management scripts as they make heavy use of 'showvminfo'

comment:4 Changed 5 years ago by sc0tty

I am experiencing the same issue, with the same consequences - our automated tools grep the word FAILED to see if the command worked correctly. here is my output:

scott@WILBERFORCE:~$ VBoxManage showvminfo FESage VirtualBox Command Line Management Interface Version 2.1.0 (C) 2005-2008 Sun Microsystems, Inc. All rights reserved.

Name: FESage Guest OS: Windows XP UUID: b26875db-7287-439d-8f91-59f642ca2ba3 Config file: /mnt/raid1reiser/home/scott/.VirtualBox/Machines/FESage/FESage.xml Memory size: 512MB VRAM size: 8MB Boot menu mode: message and menu ACPI: on IOAPIC: off PAE: on Time offset: 0 ms Hardw. virt.ext: on Nested Paging: off VT-x VPID: off State: running (since 2008-12-19T10:47:58.458000000) Monitor count: 1 3D Acceleration: off Floppy: empty SATA: disabled IDE Controller: PIIX3 Primary master: /mnt/raid1reiser/home/scott/VDI/XP-TIMserver.vdi (UUID: e7a7af3d-317d-40cf-6991-7fc505def014) DVD: Host drive /dev/scd0 NIC 1: MAC: 080027D520B5, Attachment: Host Interface 'br0', Cable connected: on, Trace: off (file: none), Type: Am79C970A, Reported speed: 1000 Mbps NIC 2: disabled NIC 3: disabled NIC 4: disabled NIC 5: disabled NIC 6: disabled NIC 7: disabled NIC 8: disabled UART 1: disabled UART 2: disabled Audio: disabled (Driver: Unknown, Controller: Unknown) Clipboard Mode: Bidirectional Video mode: 1272x800x32 VRDP: enabled (Address 0.0.0.0, Port 3391, MultiConn: off, ReuseSingleConn: off, Authentication type: null) USB: disabled

USB Device Filters:

<none>

Available remote USB devices:

<none>

Currently Attached USB Devices:

<none>

Shared folders:

Name: 'sage', Host path: '/var/sage' (machine mapping), writable

[!] FAILED calling remoteDisplayInfo->GetActive (&Active) at line 1511! [!] Primary RC = E_ACCESSDENIED (0x80070005) - Access denied [!] Full error info present: true , basic error info present: true [!] Result Code = E_ACCESSDENIED (0x80070005) - Access denied [!] Text = The object is not ready [!] Component = RemoteDisplayInfo, Interface: IRemoteDisplayInfo, {550104cd-2dfd-4a6c-857d-f6f8e088e62c} [!] Callee = IRemoteDisplayInfo, {550104cd-2dfd-4a6c-857d-f6f8e088e62c} scott@WILBERFORCE:~$

comment:5 Changed 5 years ago by frank

Please could you stop posting of such output! I already confirmed that we are aware of this problem. We will fix it with the next release.

Apart from this be aware that the output of VBoxManage can change with every version. It is just like the /proc file system of Linux. We will even remove the machinereadable output in some future release. The reason is that this is not maintainable. If you need this information you should use the SDK and collect these information directly by writing your own application. The source code of VBoxManage is a good example how to do this.

comment:6 Changed 5 years ago by frank

  • Summary changed from remoteDisplayInfo not active after starting VBoxHeadless machine to remoteDisplayInfo not active after starting VBoxHeadless machine => Fixed in SVN

comment:7 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use