VirtualBox

Ticket #2758 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

VirtualBox Failed to update VM configs

Reported by: luizluca Owned by:
Priority: major Component: network
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: other
Host type: Linux

Description

After upgrade to 2.1, all my VM with a configuration similar to the bellow failed

<Network>

<Adapter slot="0" enabled="true" MACAddress="080027FE48E1" cable="true" speed="0" type="Am79C973">

<HostInterface TAPSetup="/home/luizluca/prog/bash/vboxnet nat" TAPTerminate="/home/luizluca/prog/bash/vboxnet off"/>

</Adapter> <Adapter slot="1" enabled="false" MACAddress="080027E9274C" cable="true" speed="0" type="Am79C973"/> <Adapter slot="2" enabled="false" MACAddress="080027EB9935" cable="true" speed="0" type="Am79C973"/> <Adapter slot="3" enabled="false" MACAddress="080027D54AD0" cable="true" speed="0" type="Am79C973"/>

</Network>

The error was:

Assertion failed: [!name.isNull()] at '/home/vbox/vbox-2.1.0/src/VBox/Main/NetworkAdapterImpl.cpp' (1068) in nsresult NetworkAdapter::loadSettings(const settings::Key&). Please contact the product vendor!.

Código de Resultado: NS_ERROR_FAILURE (0x80004005) Componente: NetworkAdapter Interface: INetworkAdapter {a876d9b1-68d9-43b1-9c68-ddea0a473663}

Change History

comment:1 Changed 5 years ago by patrik77

I had the exact same problems for all my machines using custom network startup and shutdown scripts. I have posted the steps I took to get the machine configurations converted and working here:  http://patrik.cqure.net/wordpress/2008/12/17/virtualbox-21-new-release-new-problems/

comment:2 Changed 5 years ago by dmik

  • Status changed from new to closed
  • Resolution set to fixed

Confirmed. Thank you for reporting; the problem was fixed and the fix will appear in the next bug fix release (soon).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use