VirtualBox

Ticket #2757 (closed defect: fixed)

Opened 5 years ago

Last modified 2 years ago

Windows XP Guest report conflict IP

Reported by: axet Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Host: Fedora 10 Guest: Windows XP

connection type for guest: Host interface.

I think windows ask mac address for current ip which result as two machines respond, first guest os second my host (fedora 10). That procedure done by ARP protocol.

Attachments

VBox.log Download (47.7 KB) - added by axet 5 years ago.

Change History

comment:1 Changed 5 years ago by axet

Internet and local resources works fine for booth machines.

Booth machines have dhcpd address

comment:2 Changed 5 years ago by frank

  • Host type changed from other to Linux

Both, your guest and your host, should have different MAC addresses (please can you confirm that)? Please could you attach a VBox.log for such a session?

Changed 5 years ago by axet

comment:3 Changed 5 years ago by axet

Confirm!

host: wlan0 Link encap:Ethernet HWaddr 00:19:E3:D3:7B:51

guest 080027C487F7

comment:4 Changed 5 years ago by axet

what is wounder: everyting works fine! i can connect to all dirrections! from VB to all network, and oposite direction - amazing! you made a real bridge! but still persist that strange problem with mac conflits

comment:5 follow-up: ↓ 10 Changed 5 years ago by frank

Ah, I saw your VBox.log. This works as intended. You attached your VM to a wireless interface. As wlan devices often do not support the promiscous mode we automatically switch to another mode where host and guest share the same MAC address.

comment:6 Changed 5 years ago by axet

here a mistake:

[root@axet-laptop axet]# tcpdump -i wlan0

dmesg:
device wlan0 entered promiscuous mode

comment:7 Changed 5 years ago by Cruicky

This also happens for linux guests too.

[ 203.156162] eth0: duplicate address detected!

Running wireshark in the VM shows that every packet the virtual machine is sending gets replayed back to it, which is probably why the duplicate address detection logic is firing. Below is the DHCP traffic shown in the VM when trying to acquire the address.

11 10:34:38.004733 0.0.0.0 255.255.255.255 DHCP DHCP Discover - Transaction ID 0x6dfef679

12 10:34:38.013964 0.0.0.0 255.255.255.255 DHCP DHCP Discover - Transaction ID 0x6dfef679

13 10:34:38.013964 192.168.96.1 192.168.96.34 DHCP DHCP Offer - Transaction ID 0x6dfef679

14 10:34:38.020888 0.0.0.0 255.255.255.255 DHCP DHCP Request - Transaction ID 0x6dfef679

15 10:34:38.024111 0.0.0.0 255.255.255.255 DHCP DHCP Request - Transaction ID 0x6dfef679

16 10:34:38.024203 192.168.96.1 192.168.96.34 DHCP DHCP ACK - Transaction ID 0x6dfef679

You can clearly see the packets originating from the VM are being replayed back. This is the same for any packet leaving the VM, be it TCP, UDP or ICMP.

comment:8 Changed 5 years ago by Cruicky

I should add this is on a wired interface, not a wireless interface.

comment:9 Changed 5 years ago by aleksey

The example of DHCP traffic shows duplicated DHCP Discover & Request packets which are broadcast packets. These packets are transmitted to both host and wire. This is completely normal for them to appear in wireshark twice since it picks up both packets, the one going up the host's stack and the one going down. This applies to broadcast packets only. I confirm that there is a bug causing unicast packets to be sent both to host and guest as well. The problem with duplicate ARP responses is not necessarily related to it.

comment:10 in reply to: ↑ 5 Changed 5 years ago by grayfox

Replying to frank:

Ah, I saw your VBox.log. This works as intended. You attached your VM to a wireless interface. As wlan devices often do not support the promiscous mode we automatically switch to another mode where host and guest share the same MAC address.

I have the same problem. I am running VB 2.1.0 on Fedora 10 with WinXP (SP3) as a guest. When I choose eth1 ( my wireless interface ) everything works fine except WinXP is constantly whining about a duplicate IP.

My only connection is via wireless!

Prior to 2.1.0 I used the tap interface and the arp proxy parprouted and everything worked well... regrettably this technique has been broken/removed with VB 2.1.0

Is there anyway to suppress the constant complaints about a duplicate IP ? ( This does not seem likely in view of your comment )...

comment:11 follow-up: ↓ 12 Changed 5 years ago by daanemanz

I can confirm this; running VB 2.1.0 on Ubuntu 8.10 32 bit with WinXP SP3 as a guest.

The duplicate IP problem already arises while installing WinXP.

comment:12 in reply to: ↑ 11 Changed 5 years ago by sh0

It looks like a malfunction of the new Host Interface Networking.

The Host Interface replies and thinks it's responsible for all IPs requested and offered to the Windows client. This obviously happens after a while using some VMs.

VBox: 2.1.0
Host: Arch Linux x86_64
Guests: Debian Linux 4.0 and Debian-Live booted via TFTP/NFS

tcpdump:

XX:XX:XX:XX:a4:2e VBox bridged host-interface
XX:XX:XX:XX:cc:36 DHCP Server (No VM)
XX:XX:XX:XX:ce:ec Windows 2000 or XP Client (No VM)

XX:XX:XX:XX:cc:36 > ff:ff:ff:ff:ff:ff, ... , Request who-has 192.168.X.147 tell 192.168.X.1, length 46
XX:XX:XX:XX:a4:2e > XX:XX:XX:XX:cc:36, ... , Reply 192.168.X.147 is-at XX:XX:XX:XX:a4:2e, length 28
XX:XX:XX:XX:ce:ec > ff:ff:ff:ff:ff:ff, ... , Request who-has 192.168.X.147 tell 192.168.X.147, length 46
XX:XX:XX:XX:a4:2e > XX:XX:XX:XX:ce:ec, ... , Reply 192.168.X.147 is-at XX:XX:XX:XX:a4:2e, length 28

and so on ...

The DHCP-Server ARP table is growing continuously:

192.168.X.127 ether XX:XX:XX:XX:A4:2E C eth0
192.168.X.125 ether XX:XX:XX:XX:A4:2E C eth0
192.168.X.147 ether XX:XX:XX:XX:A4:2E C eth0
...
192.168.X.154 ether XX:XX:XX:XX:A4:2E C eth0

comment:13 Changed 5 years ago by frank

  • Component changed from network to network/hostif

comment:14 Changed 3 years ago by aleksey

Does anybody have this problem (XP guest complaining about IP address conflict) with recent versions of VirtualBox?

comment:15 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use