VirtualBox

Ticket #2748 (closed defect: fixed)

Opened 7 years ago

Last modified 10 months ago

Using fullscreen programs on a GNU/Linux guest with Guest Additions removes all resolutions from Xorg -> fixed in 4.2 series and later releases after 8 September 2014

Reported by: Samus_Aran Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description (last modified by michael) (diff)

After loading up a fullscreen program, such as TuxPaint, then exiting the program, Xorg has no resolutions available and the desktop believes the resolution to be 0x0 pixels.

Sample commands and their output:

$ xrandr Screen 0: minimum 64 x 64, current 1440 x 900, maximum 32000 x 32000 VBOX1 connected 1440x900+0+0 0mm x 0mm

1440x900 60.0*+ 59.9 60.0* 1280x960 60.0 1360x768 59.8 1152x864 60.0 1280x720 60.0 1024x768 60.0 60.0 800x600 60.3 60.0 640x480 59.9 60.0 320x200 60.0

$ tuxpaint --fullscreen $ xrandr xrandr: output VBOX1 cannot use rotation "normal" reflection "none"

I have tested this from a failsafe terminal, with no window manager present at all.

Additionally, the mouse does not line up with the cursor when in a fullscreen program, probably related to the low resolution used. This bug has already been reported by someone else.

Disabling the mouse integratation solves the mouse-alignment-at-low-resolutions issue.

Disabling the accellerated driver and instread using the "vesa" driver solves the exiting-fullscreen-breaking-Xorg issue.

Neither "fix" is ideal, VESA mode is extremely slow for basic 2D graphics.

I can provide any and all information that is required to debug this issue, just let me know what is needed.

Attachments

VBox.log.bz2 Download (63.0 KB) - added by Maazl 10 months ago.
Xorg.0.log.bz2 Download (6.3 KB) - added by Maazl 10 months ago.

Change History

comment:1 Changed 7 years ago by Samus_Aran

I forgot to use a code block and the console example came out badly formatted. Repasting it here:

$ xrandr
 
Screen 0: minimum 64 x 64, current 1440 x 900, maximum 32000 x 32000
VBOX1 connected 1440x900+0+0 0mm x 0mm
   1440x900       60.0*+   59.9     60.0* 
   1280x960       60.0  
   1360x768       59.8  
   1152x864       60.0  
   1280x720       60.0  
   1024x768       60.0     60.0  
   800x600        60.3     60.0  
   640x480        59.9     60.0  
   320x200        60.0  
 
$ tuxpaint --fullscreen
 
$ xrandr
 
xrandr: output VBOX1 cannot use rotation "normal" reflection "none"

comment:2 Changed 7 years ago by Samus_Aran

All aspects of this bug still exist in 2.1.0.

comment:3 Changed 7 years ago by sandervl73

  • Version changed from VirtualBox 2.0.6 to VirtualBox 2.1.0

comment:4 Changed 10 months ago by Maazl

The problem with fullscreen applications in the guest still exists in VirtualBox 4.3.14 with headless VMs. E.g. running frozen-bubbles. Press 'f' once and the game switches to fullscreen. Press 'f' again and the screen got corrupted. Running xrandr shows the error xrandr: output VBOX1 cannot use rotation "normal" reflection "none"

The following sequence recovers from the problem:

  • Open a ssh terminal.
  • export DISPLAY=:0
  • xrandr --output VBOX0 --rotate normal

Sometime additionally the following command is required

  • xrandr --output VBOX0 --auto

Once done the screen output is no longer currupted. But if you switch to fullscreen and back again the screen is again corrupted.

Since the screen corruption is not always the same, it might be a race condition while restoring the original desktop resolution.

Test conditions: host: AMD64, Debian Wheezy VirtualBox: 4.3.14 guest: Linux Mint 17 Mate (32 bit) Guest additions: 4.3.14 test application: frozen-bubbles

But I have seen the same problem with other guests and applications as well. E.g. Xubuntu 12.04 or Wine fullscreen applications (switching with Alt-Enter).

vbox.log attached, xorg.log attached

Changed 10 months ago by Maazl

Changed 10 months ago by Maazl

comment:5 Changed 10 months ago by michael

  • Description modified (diff)

I'm afraid that I missed this when it was first created. I can reproduce it locally, though without screen corruption. It would be interesting to have a minimal test case X11 client.

comment:6 Changed 10 months ago by michael

Never mind, I think I have found the bug in my code, and am testing now.

comment:7 Changed 10 months ago by michael

  • Summary changed from Using fullscreen programs on a GNU/Linux guest with Guest Additions removes all resolutions from Xorg to Using fullscreen programs on a GNU/Linux guest with Guest Additions removes all resolutions from Xorg -> fixed in 4.2 series and later releases after 8 September 2014

Committed the fix. It will be present in any 4.2 series or later releases after today.

comment:8 Changed 10 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.16.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use