VirtualBox

Ticket #272 (closed defect: worksforme)

Opened 7 years ago

Last modified 5 years ago

FreeBSD Guest loses control

Reported by: hron84 Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.8 Keywords: freebsd
Cc: Guest type: BSD
Host type: other

Description

The SVN version is very interest: when I boot up a FreeBSD guest I fully lose the control after a some time. Not accept events from keyboard, nor from mouse. SVN is checked out this day (04/15/07).

Change History

comment:1 Changed 7 years ago by hron84

I not modified the Version, is related to SVN version. I'm sorry.

comment:2 Changed 7 years ago by achimha

Do you want to say that you have modified the code and that it is not a problem in SVN? From what we know, FreeBSD works perfectly well with the current SVN -- we spent a lot of time fixing and optimizing it.

comment:3 Changed 7 years ago by hron84

No, i'm not modified the code, i simply checked out the svn tree, and compiled it by your recommended method ( http://www.virtualbox.org/wiki/Linux%20build%20instructions). The FreeBSD setup was terminated correctly, and when I start a virtual machine with a new system, it's works, but, when i take a control to host (for example while i compile something) and i want give a control again to guest after some time, i can't control a guest by mouse nor keyboard. The guest is works, but i can't do anything from a "real" console (for example, by SSH i can control it). I don't know programming in C/C++, and I can't tell you a exact lace of error. I'm a simple user... :( But, the problem isn't appears with a DOS 6.22 or Linux guest. Do you think, i change the "operating system profile" to (for example) Linux, my problem is will vanished?

comment:4 follow-up: ↓ 5 Changed 7 years ago by klaus

The operating system profile just selects which icon to display in the GUI. Nothing more. In particular it doesn't affect the operation of the virtualization core in any way.

So what you report seems to indicate a problem with the keyboard/mouse device seen by a FreeBSD guest. Do you get any keyboard/muse-related error messages in the guest's syslog or on the host in ~/.VirtualBox/Machines/VMNAME/Logs/VBox.log?

comment:5 in reply to: ↑ 4 Changed 7 years ago by hron84

I don't known very well the FreeBSD, but I experienced it sends its "problems" to the active console. But, I didn't see any log message in console whet the problem is experienced.

VBox.log? Hmmm... I didn't see it. I will do same test, and i attach the log, if the problem will be experienced.

Thanks a lot of help. Sinc: G.

comment:6 Changed 6 years ago by frank

  • Guest type changed from other to BSD

comment:7 Changed 6 years ago by frank

Is this bug still relevant?

comment:8 Changed 5 years ago by attoparsec

  • Status changed from new to closed
  • Resolution set to worksforme

comment:9 Changed 5 years ago by attoparsec

This works here with 2.1.2 and FreeBSD 7.1. I close this ticket due to feedback timeout. If it is still a problem, please re-open.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use