VirtualBox

Ticket #2692 (closed defect: duplicate)

Opened 5 years ago

Last modified 9 months ago

Win key sticks upon locking computer on Vista -> duplicate of #2537

Reported by: drewunwired Owned by:
Priority: minor Component: GUI
Version: VirtualBox 2.0.6 Keywords: vista stuck key
Cc: Guest type: Linux
Host type: Windows

Description (last modified by michael) (diff)

The best way I can describe the bug is to show how to reproduce it: Host: Vista x86 with VT-x enabled Guest: Ubuntu 8.04 (Hardy) x86 with Guest Additions installed

  1. Start up guest (Seamless mode optional).
  1. Give the VM focus, but keep the cursor out of the guest window(s) (so host gets keyboard input)
  1. Lock the computer by holding the Windows flag key (either left or right) and hitting L.
  1. Try to enter a lowercase 'u' on the password screen only to get the Ease of Access dialog to pop up instead (as what happens when you hit Win+U).
  1. Hit the Windows key once to reset the Win key sticking.
  1. Observe that you can now properly type a lowercase 'u' without issues.

Workaround:

Give another application focus before locking the screen.

Change History

comment:1 Changed 5 years ago by macias

Still happens for 3.0.8 -- for me it happens more often and step for reproduce is way more simpler.

  1. switch to guest (windows, in my case, XP)
  2. press and release win key
  3. now entire windows behaves like win key is pressed down, so when you press for example O, it is interepreted, as win+O
  4. press and release win key
  5. now windows thinks (by accident) the win key is released

since I use win+tab to switch windows (not MS-Windows) in host system (opensuse) and of course I switch to VB as well, every second switch to VB I have problems with typing because I have to remember to press win+tab, win just to avoid win key "stuck down".

Please upgrade the status to normal, because it happens always and it is very annoying.

comment:2 Changed 3 years ago by jouda

Virtual Box v3.2.8. The issue with stuck Win-key is still present on Windows XP :(

comment:3 Changed 3 years ago by frank

  • Component changed from host support to GUI

comment:4 Changed 12 months ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)
  • Summary changed from Win key sticks upon locking computer on Vista to Win key sticks upon locking computer on Vista -> duplicate of #2613

I will close this as a duplicate of #2613. Please re-open if you disagree.

comment:5 Changed 9 months ago by michael

  • Summary changed from Win key sticks upon locking computer on Vista -> duplicate of #2613 to Win key sticks upon locking computer on Vista -> duplicate of #2537

Duplicate of #2537 in fact.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use