VirtualBox

Ticket #2685 (closed enhancement: duplicate)

Opened 5 years ago

Last modified 4 years ago

LPT Interface Support in Virtualbox

Reported by: q10 Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.6 Keywords: parallel LPT1 port
Cc: Guest type: other
Host type: other

Description

Please have support for parallel port interfaces (i.e. LPT1, LPT2, LPT3, etc) in addition to support for COM (/dev/ttyS) interfaces in VirtualBox.

Change History

comment:1 Changed 5 years ago by drpepit

Hi, I'm running Virtualbox on Ubuntu 8.10 (dual Opteron machine 64 bit) WIN 98 SE virtual machine hoping to use an old scanner Trust Easy Scan 9600 connected to the parallel port for which are available only WIN 98 drivers. Ubuntu has 2 devices /dev/lp0 and /dev/parport0 and I'd like to use the scanner but scanner test says nothing is connected to the parallel port. I'd be grateful if anybody can help, thanks

comment:2 Changed 5 years ago by maxlem

I'd need a parallel port for light CNC machining, lots of people needs it for licensed software dongle. Please add support for paralell port

comment:3 in reply to: ↑ description Changed 5 years ago by tgaleta

It would be great to use good old plotter with original drivers through parallel port. Please, support it. Thanks!

comment:4 Changed 5 years ago by jpvbox

VirtualBox already has support for parallel ports, but is untested/unofficial i guess, you can use it but not from the regular frontend, you can try frontend like virt-manager with libvirt >= 0.6.3 to use the parallel ports in virtualBox, check this site for more info:  http://libvirt.org/drvvbox.html. it gives the details for all devices which can be created using libvirt driver for virtualbox. the frontend for libvirt is virt-manager or ovirt which can be found at:  http://virt-manager.et.redhat.com/

comment:5 Changed 5 years ago by Technologov

This bug looks like a duplicate of bug #990

-Technologov

comment:6 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Right, this is a duplicate of #990.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use