VirtualBox

Ticket #2654 (closed defect: fixed)

Opened 5 years ago

Last modified 5 months ago

DNS stopped working (NAT)

Reported by: greenrd Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 2.0.6 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description (last modified by Hachiman) (diff)

As I was browsing the web (going to fedoraproject.org, as it happens) DNS stopped working on the guest (Fedora Linux rawhide). I eventually thought to check on the host and it was working there, but still not working on the host. Networking on the guest was still working (my Bittorrent download continues to transfer data). I am using NAT networking.

I have used VirtualBox for months and this has never happened before. However, I did recently upgrade to 2.0.6 (OSE).

Change History

comment:1 Changed 5 years ago by greenrd

Oops... that should say "... but still not working on the guest".

I thought that overwriting the guest's /etc/resolv.conf with the one from the guest would work around the problem, but it had no effect.

comment:2 Changed 5 years ago by greenrd

Gah! With the one from the host, I meant to say.

comment:3 Changed 5 years ago by Ormtunga

Had the same problem on my guest XP. Solved it by manually adding my DNS addresses to the network settings while keeping the IP and mask as DHCP.

comment:4 Changed 5 years ago by frank

  • Component changed from network to network/NAT

comment:5 Changed 5 years ago by greenrd

I have not experienced this problem with recent VirtualBox versions.

comment:6 Changed 5 years ago by michael

  • Status changed from new to closed
  • Resolution set to fixed

I will close the ticket then. Please re-open if necessary.

comment:7 Changed 5 years ago by raistlinkell

  • Status changed from closed to reopened
  • Resolution fixed deleted

I've just experienced "DNS stopped working with NAT" with Ubuntu 9.04 Jaunty Guest running on VBox 3.06 r52128 on a WinXP SP3 host. Guest Additions installed.

From my host I can ping and resolve DNS look-ups no problems. With the guest I can ping any internet & LAN IP address no problems but CANNOT do any DNS resolution.

I've changed the Guest Ethernet Adapter types from PCnet-II, PCnet-Fast III, to Intel Desktop and back again.. each time with the same result - Guest can ping but not resolve DNS.

This is not a new install - both host & guest have been functioning correctly for almost a month. Only today has DNS stopped working correctly on the guest.

Until this bug is resolved, i've changes to bridged adapter. Would very much like to keep the guest firewalled from the host.

comment:8 Changed 5 years ago by Hachiman

Does it happen with Vbox 3.0.8? if yes please attach log file,  pcap file and output of on host

# ipconfig /displaydns 

and

# cat /etc/resolve.conf

if it's sensible information please send information to me [vasily _dot_ levchenko _at_ Sun _dot_ COM].

comment:9 Changed 5 years ago by frank

And please attach the VBox.log file for such a session (with NAT enabled please).

comment:10 Changed 4 years ago by Hachiman

Does

VBoxManage setextradata "Linux Guest"
      "VBoxInternal/Devices/pcnet/0/LUN#0/Config/UseHostResolver" 1

fixes issue for you, with 3.1b1?

comment:11 Changed 4 years ago by Hachiman

  • Status changed from reopened to closed
  • Resolution set to fixed

No response, closing. Please reopen if problem still persists.

comment:12 Changed 5 months ago by requiredfield

I just hit this bug with the latest VirtualBox (4.3.2 r90405) running on an OS X 10.9 host and with Ubuntu and Windows 7 guests. As in the other posts above this happened without any obvious change that could have caused it after DNS had been working for months.

Changing the network adapter to bridged mode successfully works around it.

comment:13 Changed 5 months ago by Hachiman

  • Description modified (diff)

Could you please attach the log file?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use