VirtualBox

Ticket #2634 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Cannot change Shared Folder permissions

Reported by: pns Owned by:
Priority: minor Component: shared folders
Version: VirtualBox 2.0.4 Keywords: shared folders, permissions
Cc: Guest type: Linux
Host type: Windows

Description

I sucessfully auto mounted the Shared Folders with the following entry in fstab:

VM-Share /home/<user>/VM-Share vboxsf umask=026,uid=1000,gid=1000,auto 0 0

However the permissions for the folder remain 777. Also tried using chmod to change the permissions to no avail. Whatever I try the permissions always remain rwx for everyone.

I'm running Windows Vista SP1 (host) + VirtualBox 2.0.4 + Ubuntu 8.10 (guest)

Change History

comment:1 Changed 5 years ago by nmeyer

I have the same problem with a Win XP SP3 host and VirtualBox 2.0.6, in both Ubuntu 8.10 and Fedora 10 guests. Instead, I used -o uid=0,gid=501,fmask=113,dmask=002.

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Recent Linux additions provide dmode and fmode. And since VirtualBox 3.0.0 it is possible to change the permissions of a shared file between guest Linux and a host Linux.

comment:3 Changed 5 years ago by pajatopmr

  • Status changed from closed to reopened
  • Resolution worksforme deleted

I reopened this ticket since the problem exists with a Fedora 11 (64 bit host and 32 bit guest) host/guest pair. The issue is documented in the VirtualBox forum ---  http://forums.virtualbox.org/viewtopic.php?f=7&t=10535&p=96545&e=96545 --- is the last entry as of the reopening of this ticket).

To summarize, with a Fedora 11 64 bit host and a Fedora 11 32 bit guest on VirtualBox 3.0.4 (OSE), I am unable to change any permissions (chmod) for files in shared folder mounted as:

# mount -t vboxsf -o rw,exec,uid=500,gid=100 share /path/to/mount/point

As an aside, if I subsequently execute mount, I see

# mount ... share on /path/to/mount/point type vboxsf (uid=500,gid=100,rw)

Note the missing "exec". Also note that both the native root file system on both the host and guest is ext4; there does not appear to be a mount.vbox man page and the descriptions of the dmode and fmode options do not seem to fit what I want to do, i.e. have total control over the permissions of files in a shared folder; selinux is disabled on both the host and guest.

The problem could well be a Fedora bug. In which case it would be good to know if this issue does or does not exist in other Fedora releases (9 or 10 for example).

Thanks,

-pmr

comment:4 Changed 4 years ago by mcantor

Windows 7 host, Ubuntu 10.04 guest; setting fmode and dmode fixed this issue for me.

comment:5 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

pajatopmr, there is no manpage for mount.vboxsf but mount.vboxsf --help shows the available options. To change any file on the shared folder, the user which started the VM must be able to change that file so please check the same operation on the host before your try it on the guest. I've tried to reproduce your issue but failed. Please reopen if still relevant with VBox 3.2.10 (make sure to test the 3.2.10 additions as well).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use