VirtualBox

Ticket #2630 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

DNS/NAT not working when host has name server.

Reported by: qebab Owned by:
Priority: minor Component: network
Version: VirtualBox 2.0.4 Keywords: DNS
Cc: Guest type: Windows
Host type: Linux

Description

I'm using Ubuntu 8.10, and after (accidentally, I might add) installing a nameserver (bind9), DNS does not work when using the NAT adapters in the guest OS. The reason for this is that VirtualBox looks into /etc/resolv.conf to find out what nameserver to use, spies 127.0.0.1 and tries to use that. Which of course will not work given that it's the loopback for the guest OS (Or at least, I assume that's why it will not work).

The fix should be as simple as to check for that specialcase and make the guest use the IP for the host when this happens, yeah?

This isn't a big problem (Or at least won't be, when I figure out how to make my laptop use a real nameserver after removing bind).

Change History

comment:1 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #1470.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use