VirtualBox

Ticket #2628 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Guest Additions Error on server 2008 core

Reported by: earlz Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.0.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

I'm referencing ticket number #1969 as this was a problem before. I'm trying to get the guest additions installed with Server 2008 Core.

Receiving this error in the log:

Device class name: Media No devices with this name found! ERROR: Could not install files for Windows 2000 / XP / Vista! Installation aborted.

Attachments

Capture.JPG Download (137.1 KB) - added by earlz 5 years ago.
VirtualBoxWindowsCore2008.jpg Download (77.8 KB) - added by virtualtexan 5 years ago.
InstallUIDialog.jpg Download (66.4 KB) - added by virtualtexan 5 years ago.
VBoxInstallUILog.jpg Download (113.0 KB) - added by virtualtexan 5 years ago.
vbox_svr2008c_TB.jpeg Download (250.9 KB) - added by travbrack 5 years ago.
SunxVMVirtualBoxGuestAdditions.png Download (353.8 KB) - added by jhorqquep 5 years ago.
Can't install Guest Additions on Windows Server 2008 Core

Change History

Changed 5 years ago by earlz

comment:1 Changed 5 years ago by virtualtexan

Same issue here.

Changed 5 years ago by virtualtexan

comment:2 Changed 5 years ago by pentagonik

I'll take a look. Could you please post the install log (start the setup with the parameter "/L" from the command line) here? The install log is found in the Guest Additions installation directory after the installation. Thanks.

comment:3 Changed 5 years ago by pentagonik

Installed Server 2008 and tested with 2.1 Guest Additions - works fine here. What I'm wondering about: When selecting the "Core" installation you won't get a GUI at all, since this is a command line version of Server 2008!? Maybe the logs reveal something.

comment:4 Changed 5 years ago by virtualtexan

pentagonik, actually you do get the UI for the installation. That is a common misconception with Server Core. See the "InstallUIDialog.jpg" screenshot.

Unfortunately the network card isn't able to find a compatible driver so the log file is unable to be moved to a Shared Folder. See the "VBoxInstallUILog.jpg" screenshot.

Changed 5 years ago by virtualtexan

Changed 5 years ago by virtualtexan

comment:5 Changed 5 years ago by virtualtexan

Excuse the stupid mistake, attached the same log as the original ticket. What is the logged named? I didn't see a different file aside from the install_ui.log.

Changed 5 years ago by travbrack

comment:6 Changed 5 years ago by travbrack

Same problem here. Ubuntu 8.10, vbox 2.0.4. I had trouble getting file sharing to work so I posted the previous screenshot

comment:7 Changed 5 years ago by travbrack

Same issue still exists in 2.1.2

comment:8 Changed 5 years ago by xmaes

same issue here in 2.1.4 same log as VBoxInstallUILog.jpg

comment:9 Changed 5 years ago by weemat

I had the same issue trying to install additions on Server Core 2008 R2 (X64 obviously) guest running on xVM VirtualBox 2.1.4 on Win7 (X64).

I used pnputil instead to do the 3 drivers. pnputil /? has syntax. I extracted vboxwindowsaddtions-amd64.exe with /extract switch. it is extracted to Virtualbox install folder in c:\program files. The pointed at each inf using pnputil and installed.

Please remember to force remove the failed package (from the setup) before using pnputil. I didnt use vboxdrvinst.exe to install any drivers but its syntax gives a hint why the failure may occur. The GUI setup seems to attempt using Media as device class name instead of display. When using the vboxdrvinst.exe example given for installing display driver, no errors are reported.

Still even after installing the 3 drivers, installing the vboxservice.exe , setting service to auto, I still cant move the mouse seamlessly between guest and host. Not sure if there is any reg hacks also required.

comment:10 Changed 5 years ago by weemat

just to add I noticed that after all of above the vboxmouse.sys was not installed in c:\windows\system32\drivers. I copied file manually and exported HKLM\System\CurrentControlSet\Services\VBOxMouse and imported to core machine. Still no luck. I hope someone gets assigned and looks into this.

Thanks guys. This is a really good product and what I rely on while I wait for VPC 2007 to add 64-bit guest support.

comment:11 Changed 5 years ago by jhorqquep

Again same issue with VirtualBox 2.2.0 R45846

Changed 5 years ago by jhorqquep

Can't install Guest Additions on Windows Server 2008 Core

comment:12 follow-up: ↓ 13 Changed 5 years ago by chungy

I was able to manually get the guest additions drivers installed and the service started:

  1. Select "Install Guest Additions"; it will not start up automatically (this is a good thing actually), but will insert the iso into the virtual CD drive
  1. Change to the D: drive by simply typing "D:"
  1. Extract files: VBoxWindowsAdditions.exe /extract
  1. Change to C: again with "C:"
  1. Change to the guest additions directory with: cd "C:\Program Files\Sun\xVM VirtualBox Guest Additions\x86" (or x64 on 64-bit versions)
  1. Install drivers:

pnputil -i -a VBoxGuest\VBoxGuest.inf pnputil -i -a VBoxMouse\VBoxMouse.inf pnputil -i -a VBoxVideo\VBoxVideo.inf

  1. Reboot
  1. Install guest service: "C:\Program Files\Sun\xVM VirtualBox Guest Additions\x86\Bin\VBoxService.exe" /i
  1. Make the service automatically start on bootup: "sc config VBoxService start= auto" (the space before 'auto' is necessary)
  1. Start guest service: net start VBoxService

After that, most things are working... seamless mouse integration, resizing the guest display, time sync. Seamless windows does not seem possible as it depends on VBoxTray which uses Explorer, and that's not installed in server core. Would be nice if the additions installer can steamline all the steps and make it not so much busy work :-)

comment:13 in reply to: ↑ 12 Changed 5 years ago by chungy

I feel a little stupid now... I reinstalled Server Core, but now I can't get mouse integration to work. My instructions above didn't work, I tried a few variations... no luck. This is quite odd because I know I got it working before without much trouble; I don't know what changed.

Oh well, I suppose, everything else seems to work fine, the mouse isn't the most important part.

comment:14 Changed 5 years ago by pentagonik

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the information. This will be fixed in the next upcoming release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use