VirtualBox

Ticket #2600 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

VirtualBox x64 guest crashes periodically, reason unknown, log attached

Reported by: descentspb Owned by:
Priority: critical Component: other
Version: VirtualBox 2.0.4 Keywords: crash, x86-64
Cc: Guest type: Linux
Host type: Linux

Description

I have an ubuntu server x64 guest machine running with VBoxHeadless in the background (with "/usr/bin/screen"). Sometimes I realize that it does not work anymore, but I can't afford that, cause this is a production server. The only clue I have are the logs, cause VBox does not produce any other messages, just kills the machine or closes the window (if I catch the error while running in the X environment).

This is what the log (which I think corresponds to the error) ends with:

00:00:06.643 Guest Log: BIOS: int13_harddisk: function 02, ELDL out of range 8F 00:00:06.755 PIT: mode=2 count=0x2e9c (11932) - 99.99 Hz (ch=0) 00:00:07.565 PIT: mode=0 count=0x10000 (65536) - 18.20 Hz (ch=0) 00:00:10.128 PIIX3 ATA: Ctl#0: RESET, DevSel=0 AIOIf=0 CmdIf0=0x20 (-1 usec ago) CmdIf1=0x00 (-1 usec ago) 00:00:10.128 PIIX3 ATA: Ctl#0: finished processing RESET 00:00:10.288 PIIX3 ATA: Ctl#1: RESET, DevSel=0 AIOIf=0 CmdIf0=0xa0 (-1 usec ago) CmdIf1=0x00 (-1 usec ago) 00:00:10.288 PIIX3 ATA: Ctl#1: finished processing RESET 00:00:20.046 PCNet#0: Init: ss32=1 GCRDRA=0x048ad000[32] GCTDRA=0x07870000[16] 10:38:05.818 10:38:05.818 !!Assertion Failed!! 10:38:05.818 Expression: i < 4096 10:38:05.818 Location : /home/vbox/vbox-2.0.4/src/VBox/Runtime/r3/linux/semevent-linux.cpp(188) int RTSemEventSignal(RTSEMEVENTINTERNAL*) 10:38:05.861 iCur=0x1 pThis=0000000001834fe0

I have noticed that the log tail is always the following:

02:44:29.618 !!Assertion Failed!! 02:44:29.618 Expression: i < 4096 02:44:29.618 Location : /home/vbox/vbox-2.0.4/src/VBox/Runtime/r3/linux/semevent-linux.cpp(188) int RTSemEventSignal(RTSEMEVENTINTERNAL*) 02:44:29.665 iCur=0x1 pThis=0000000002693430

Change History

comment:1 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Another duplicate of #616.

comment:2 Changed 5 years ago by frank

Please have a look at #616, perhaps you could provide a core dump?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use