VirtualBox

Ticket #258 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

User Manual 1.3.8 Bugs

Reported by: Risto Owned by:
Priority: minor Component: other
Version: VirtualBox 1.3.8 Keywords: user manual bugs, tips
Cc: Guest type: other
Host type: other

Description

Some manual bugs found:

  1. Page 12. Note.

"Presently VirtualBox can only be run from user accounts with administrator rights. This will be fixed in a future release."

I believe you have fixed this, as I can run VirtualBox under Windows XP host under normal (restricted) user account.

*

  1. Page 16. Manual installation, creating links.

"ln -sf /opt/VirtualBox/VBox.sh /usr/bin/VirtualBox ln -sf /opt/VirtualBox/VBox.sh /usr/bin/VBoxSVC ln -sf /opt/VirtualBox/VBox.sh /usr/bin/VBoxManage"

In this case all commands point to same shell script. Is this correct?

*

  1. Page 17.

"As a result, prior to starting one of the VirtualBox application programs, the service daemon must be started: export LD_LIBRARY_PATH=. ./VBoxSVC"

If it should be 2 bash commands, then there should be ; between.

*

  1. Page 17.

"All VirtualBox applications (VirtualBox, VBoxSDL, VBoxManage and VBoxVRDP) require the VirtualBox directory to be in the library path: export LD_LIBRARY_PATH=. ./VBoxManage showvminfo "Windows XP""

Same as point 3.

*

  1. Page 38, VDI.

Not a bug - but a tip. One could find useful to use write-through or immutable VDI hard disk image for Windows page-files or Linux Swap partitions. This way the Snapshots won't grow larger due to changes in swap partition/page file. In this point would surely be nice to include a step-by-step instruction in the manual of moving Windows page file to other HDD/partition.

*

  1. Page 62.

"Only images that have previously been registered with VirtualBox can be set to immutable, as the property is set in VirtualBox's configuration and not in the disk image file itself."

Doesn't this apply to write-through disk images as well?

*

  1. Page 55.

In the list is written: "VBoxManage modifyvdi <uuid>|<filename> compact"

The options immutable and write-through are missing.

*

  1. Page 20.

"particular virtual machine, while that VM is running, you will only have 512 MB left for all the other software software on your host."

Double word "software"

*

  1. Page 21

"After having selected or created your VDI file, again press "Next" to go the next page." -> "After having selected or created your VDI file, again press "Next" to go to the next page."

*

  1. Page 22

"The various settings that can be changed in the "Settings" window are described in detail in in Section 5.1, “Virtual machine settings”."

Double word "in".

*

  1. Page 23

"Since the operating system in the virtual machine does not "know" that is not running" -> "Since the operating system in the virtual machine does not "know" that it is not running"

*

  1. Page 24

"Third, also with Linux, the key combination Ctrl+Alt+Fx (where Fx is one of the function keys from F1 to F12) normally allows to to switch"

Double word "to"

*

  1. Page 26.

"1. You can only take a snapshot if your VM is in the "saved" or "powered off" state (as displayed next to the VM in the VirtualBox main window). So, if your VM is not running, close it and have its state saved to disk."

Should probably be (without NOT): "... So, if your VM is running, close it.."

*

  1. Page 26.

"3. A window will up and ask you..." -> "3. A window will pop up and ask you..."

*

  1. Page 29.

"You will only have one mouse pointer any more, and pressing the Host key is no longer required to "free" the mouse from being captured by the guest OS." -> "You will only have one mouse pointer and pressing the Host key is no longer required to "free" the mouse from being captured by the guest OS."

*

  1. Page 66.

"The VirtualBox Guest Additions for Windows come with such a GINA module which and can therefore perform automated logons." -> "The VirtualBox Guest Additions for Windows come with such a GINA module and can therefore perform automated logons."

*

  1. Page 30.

"As VirtualBox can provide ISO files as a virtual CD-ROM drive to the Windows guest, Windows can automatically install these additions." -> "As VirtualBox can provide ISO files as a virtual CD-ROM drives to the guest(s), Windows can automatically install these additions."

*

  1. Page 30. Tip.

I would use instead: "If the menu item does not work, you can perform the following steps manually:" following: "In case you prefer to mount the additions manually, you can perform the following steps:"

*

  1. Page 34. Tip.

Enable I/O APIC. No clear description IMHO, why should one enable I/O APIC in VM in the first place.

*

  1. Page 34.

"BIOS logo cutomization" -> "BIOS logo customization"

*

  1. Page 34. Tip

"BIOS logo customization" topic is a bit off-place under 5.1.1 General settings, as this item is not available in (1.3.8) GUI.

*

  1. Page 35.

"For both the floppy and and CD/DVD-ROM categories"

Double word "and".

*

  1. Page 59. PDF-Link does not work.

Section 5.1.3, "CD/DVD-ROM and floppy settings".

*

  1. Page 72.

Ill-wrapped URL: "ht-  tp://www.amd.com/us-en/ConnectivitySolutions/ProductInformation/0,,50_2330_6629_2452%5E24 54%5E2486,00.htm"

*

  1. Page 36.

"...when the guest is activated, it will be disconnected from the without a proper shutdown." -> "...when the guest is activated, it will be disconnected from the host without a proper shutdown."

Change History

comment:1 Changed 7 years ago by achimha

  • Status changed from new to closed
  • Resolution set to fixed

Errors have been corrected. Thanks a lot!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use