VirtualBox

Ticket #2574 (closed enhancement: wontfix)

Opened 5 years ago

Last modified 4 years ago

MacOS VM windows should be labeled with the VM name

Reported by: jimlaurent Owned by:
Priority: minor Component: GUI
Version: VirtualBox 2.0.4 Keywords:
Cc: Guest type: Solaris
Host type: Mac OS X

Description

In MacOS VBOX 2.0.4 labels its virtual machine windows as "VirtualVM." This name appears on the dock and in the pick list when you do command-tab to switch applications. Instead of a generic name, the name of the specific VM should be used.

Change History

comment:1 Changed 4 years ago by Technologov

I totally agree on this. This usability issue exists in VBox 3.0.8. Tested on Mac OS X 10.5.6. But I believe this is a feature-request, not a bug.

-Technologov

comment:2 Changed 4 years ago by frank

AFAIK, the label of a window can't be easily changed on Mac OS X, that's the reason why we didn't do this already.

comment:3 Changed 4 years ago by sandervl73

  • Type changed from defect to enhancement

comment:4 Changed 4 years ago by poetzsch

  • Status changed from new to closed
  • Resolution set to wontfix

You are absolute right. The problem is that Mac OS X displays the process name there and unfortunately this can't be changed at runtime. So it is not possible to show anything more useful there. Sorry.

comment:5 Changed 4 years ago by Technologov

Before closing let's discuss it a bit.

In VirtualBox, every VM is a separate process. So a VM Window can have a Window Name that corresponds to VM Name (during VM Window creation).

What do you think of it ?

-Technologov

comment:6 Changed 4 years ago by poetzsch

The window name is changed as you may noticed. But as I wrote in the command-tab list the process name is displayed. The process name is fetched from the plist file which reside in the VirtualBoxVM application folder. To change the name displayed there, we have to change the plist file before starting the VM sub process which is *no* option. If someone knows another way to solve this problem, please let us know & we will try it out.

comment:7 Changed 4 years ago by meatmanek

It might be possible to create and keep a new .app folder for each virtual machine, with its own Info.plist. This would also have the added benefit that it would allow the user to keep virtual machines in the dock as separate applications or to launch a VM on startup/login without having to make custom scripts.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use