VirtualBox

Ticket #2559 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Auto-resize doesn't work in Ubuntu 8.10

Reported by: thomask77 Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.0.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

I just updated my Guest to Ubuntu 8.10, and also installed the current guest additions from VirtualBox 2.0.4.

Since the update, automatic guest resize doesn't work anymore. Everytime I resize the Host Window, Ubuntu switches to 1280x1024.

However, the correct Resolution is listed under System->Preferences->Screen Resolution (always as the 3rd entry in the list). It just doesn't do the right thing automatically when resizing the window.

Change History

comment:1 Changed 5 years ago by michael

  • Status changed from new to closed
  • Resolution set to wontfix

If you set the resolution using that menu entry, it will always override autoresize (Gnome always forces the resolution back to what you chose in the menu). There is some configuration file that you can delete to revert to the old behaviour. It is a known shortcoming of dynamic resizing which we will look at when we have time, but that is not likely to be in the near future. I'm afraid.

comment:2 Changed 5 years ago by thomask77

  • Status changed from closed to reopened
  • Resolution wontfix deleted

I think "wontfix" is not acceptable, as it breaks an important feature for one of the most common setups.

This will annoy every user who does a perfectly normal upgrade to Ubuntu 8.10.

The guest addition installer should take care of it.

At least leave this bug "open" until it's fixed.

comment:3 Changed 5 years ago by michael

"wontfix" was meant as information, but if you prefer I can leave the bug open. So far you are only the second person I know of to notice the issue (the first was a developer trying out the auto-resize functionality), so you will understand that it is not our top priority. If you know of a good and reliable way to fix this though which does not require a lot of effort, please feel free to add the information here (fiddling with other applications configuration files does not count as reliable, I'm afraid). As an alternative you might consider asking Gnome/Ubuntu to change their default behaviour and not force the desktop back into a particular resolution when the resolution is changed by another application.

(By the way, the file to be changed to disable this is apparantly ~/.gconf/desktop/gnome/screen/default/0/%gconf.xml).

comment:4 Changed 5 years ago by OxOOCOFFEE

Just to let you guys know. I did the same thing Xubunto 8.10 64-bit under Vista 64 and work really well with 2.0.4 tools

comment:5 follow-up: ↓ 6 Changed 5 years ago by Jocchan

I'm experiencing the same issue. After upgrading to Ubuntu 8.10 from an almost clean 8.04 install, the Auto-resize feature stopped working. I didn't set any resolution anywhere, and the file mentioned by Michael is nowhere to be found on my machine.

comment:6 in reply to: ↑ 5 ; follow-up: ↓ 7 Changed 5 years ago by Jocchan

Update: my problem doesn't seem related to ~/.gconf/desktop/gnome/screen/default/0/%gconf.xml at all. I tried creating it on my own, setting a resolution I'd like to start with (my Ubuntu currently boots at 640x480), and nothing happens after I reboot. I hope this additional info helps.

comment:7 in reply to: ↑ 6 ; follow-up: ↓ 8 Changed 5 years ago by michael

Replying to Jocchan: Can you try reinstalling the guest additions?

comment:8 in reply to: ↑ 7 Changed 5 years ago by Jocchan

Replying to michael:

Can you try reinstalling the guest additions?

Already tried that, and it didn't work. I ended up editing the xorg.conf file, to change the default resolution from 640x480 to the one I use (1280x702).

comment:9 follow-up: ↓ 10 Changed 5 years ago by michael

Can you try removing the xorg.conf file altogether and restarting X?

comment:10 in reply to: ↑ 9 Changed 5 years ago by Jocchan

Replying to michael:

Can you try removing the xorg.conf file altogether and restarting X?

Auto-resize works like a charm now (thank you). Apparently it was because of xorg.conf, then (which is weird, because I never edited it).

comment:11 Changed 5 years ago by zosX

I'm having a problem with this. When I install the latest release of Ubuntu 8.10 under an XP host and install the guest additions as soon as the screen resizes the graphics corrupt and the guest OS is no longer displayed (full screen mode). I've tried deleting xorg.conf as well as manually configuring it, with the vbox drivers explicitly stated. I remember 8.04 working perfectly, so it seems to be a problem with the newer kernels ubuntu 8.10 packages. If I open the screen resolution panel in Ubuntu only 800x600 and 640x480 are available options with "unknown" drivers. Forcing one of these resolutions locks it in and then resize stops working entirely. I've tried reinstalling 3 times now to no avail. The last reinstall was using the newest stable version of virtual box (2.12). Any help would be greatly appreciated.

comment:12 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 3.1.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use