VirtualBox

Ticket #2538 (closed defect: wontfix)

Opened 5 years ago

Last modified 5 years ago

Launching Windows Media Player Kills Host to Guest Clipboard Functionality

Reported by: gaborbay Owned by:
Priority: major Component: clipboard
Version: VirtualBox 2.0.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

I have been noticing that the guest to host clipboard will suddenly stop working.

I finally figured out that launching Windows Media Player is the culprit.

This is probably a bug that is not encountered very often, or it is not reported very often. But if WMP causes this issue, other apps might do it to.

To Reproduce: Launch Vbox Open Notepad in Vbox Copy Value A from the Host Past Value A to Guest Notepad (this should work fine). Launch Windows Media Player Copy Value B from Host Past Value B to Guest (it will paste Value A instead of Value B).

The only way I have found to reset the clipboard is to Shutdown Vbox Change the Shared Clipboard to "Host To Guest", Launch Vbox. Shutdown Vbox Change the Shared Clipboard to "Bi Directional Launch Vbox.

I also attached log files.

Attachments

VBox1-2008-10-30-14-03-31.log Download (33.0 KB) - added by gaborbay 5 years ago.
OS and WMP Screenshots.doc Download (84.0 KB) - added by gaborbay 5 years ago.
Host Guest and WMP Version Info

Change History

Changed 5 years ago by gaborbay

comment:1 Changed 5 years ago by gaborbay

Here's formatted version

To Reproduce:

  • Launch Vbox
  • Open Notepad in Vbox
  • Copy Value A from the Host
  • Past Value A to Guest Notepad (this should work fine).
  • Launch Windows Media Player
  • Copy Value B from Host
  • Past Value B to Guest (it will paste Value A instead of Value B).

comment:2 Changed 5 years ago by gaborbay

To clarify...it is copying from Host to Guest that stops working.

comment:3 Changed 5 years ago by sunlover

  • Component changed from shared folders to clipboard

What are exact versions of the host and the guest OS (service packs)? What is the version of the Windows Media Player? Where do you start the Media Player in the guest of on the host?

I've tried XP SP2 host and guest with MediaPlayer 9.00.00.3250 (both on host and guest). Clipboard works in this case.

comment:4 Changed 5 years ago by gaborbay

I attached screenshots of the Host, Guest and WMP version information.

I start Media Player on the Host.

Changed 5 years ago by gaborbay

Host Guest and WMP Version Info

comment:5 Changed 5 years ago by sunlover

Thanks for the information. With Media Player 11 I've reproduced the problem here. It turned out that this is not a Vbox bug, but Media Player 11 misbehaviour.

It can be reproduced with the Windows clipboard viewer. Please start clipbrd.exe (it is located in WINDOWS\system32), then copy some text from notepad. The text will appear in the clipboard viewer. Now start Media Player, copy another text from notepad. The clipboard viewer will not be updated, at least this is what I see here.

Let me know the results with clipboard viewer test. Thanks!

comment:6 follow-up: ↓ 7 Changed 5 years ago by gaborbay

Thanks for looking into this more. I don't think I totally agree with your assessment though. I think that WMP causes clipbrd.exe to stop working in the Host and Guest, but, I am still able to cut and paste within the host and within the guest. I am not able to cut and paste from the Host to Guest, but I can cut and paste from Guest to Host.

So if Cutting and Pasting functionality from Host to Guest is dependent on clipbrd.exe, then I can see why the functionality stops working because WMP causes clipbrd.exe to stop working correctly.

Please try the Following:

  • Open Clipboard View
  • Open Notepad
  • Copy a value (displays in clipboard)
  • Paste value (pastes into notepad
  • Open WMP
  • Copy a value (clipboard value does not change)
  • paste value (pastes into notepad
  • Close WMP
  • Close Clipboard
  • Open Clipboard
  • Copy a value (displays in clipboard)
  • Paste value (pastes into notepad - works as expected)
  • Start VBox
  • Open notepad in Guest
  • Open Clipboard in Guest
  • Copy a value on Host (displays in Host and Guest clipboard)
  • Paste value into Guest notepad (works as expected)
  • Start WMP
  • Copy a value on Host (does NOT display in Host or Guest clipboard)
  • Paste value into Host Notepad(pastes into notepad - works as expected)
  • Paste value into Guest Notepad(pastes the last value that was in the Guest clipboard)
  • Copy a value on Guest (does NOT display in Host or Guest clipboard)
  • Paste value into Guest Notepad(pastes into notepad - works as expected)
  • Paste value into Host Notepad(pastes the last value that was in the Guest clipboard)
  • Close Host and Guest Clipboard
  • Open Host and Guest Clipboard
  • Copy a value on Host (Host Clipboard DOES get updated, Guest clipboard DOES NOT get updated)
  • Copy a value on Guest (Host Clipboard DOES get updated, Guest clipboard DOES get updated)

So at this point we can summarize as follows:

  • I can cut and paste when I am within the Host
  • I can cut and paste when I am within the Guest
  • I CANNOT cut and paste from Host to Guest
  • I CAN cut and paste from Guest to Host

As I mentioned before, I am able to "reset" what is broken in the Guest by doing the following, which tells me that it is still a VBox issue:

To Reset Clipboard:

  • Shutdown Vbox
  • Change the Shared Clipboard to "Host To Guest"
  • Launch Vbox
  • Shutdown Vbox Change the Shared Clipboard to "Bi Directional
  • Launch Vbox.

comment:7 in reply to: ↑ 6 Changed 5 years ago by sunlover

  • Status changed from new to closed
  • Resolution set to wontfix

Replying to gaborbay:

So if Cutting and Pasting functionality from Host to Guest is dependent on clipbrd.exe, then I can see why the functionality stops working because WMP causes clipbrd.exe to stop working correctly.

Thanks for testing.

Some technical details: clipbrd.exe is the standard system utility which displays the clipboard content. VBox does not depend on clipbrd.exe and is not related to it of course, but Vbox uses the same method for tracking the host clipboard changes, that is: waiting for system notifications about clipboard changes.

The problem is that when WMP is started, VBox does not receive notifications from Windows about changed clipboard content anymore. Just like clipbrd.exe, and just like any other application which uses this, recommended, method for watching clipboard.

It is the WMP bug. Unfortunately VBox can not do much about this.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use