VirtualBox

Ticket #2502 (closed enhancement: duplicate)

Opened 5 years ago

Last modified 3 years ago

Allowing inclusion of writethough disks in snapshotted machines

Reported by: TerryE Owned by:
Priority: minor Component: other
Version: VirtualBox 2.0.4 Keywords:
Cc: Guest type: other
Host type: other

Description

Currently VBox throws an error "Cannot take a snapshot when there is a Writethrough hard disk attached" if you attempt to snapshot a machine which includes a write-through hdd. This is different to the approach taken by VMware. There are scenarios where it makes a lot of sense to allow write-through hdds to be attached to a machine that you want to snapshot and rollback, for example if you are testing but want to log test outputs permanently and which you therefore want to store on a write-through hdd.

VBox should permit you to snapshot a VM which has a write-through hdd attached, but raise a warning that "snapshot will exclude attached writethrough hard disk. Changes to writethrough hard disk will be permanent".

Change History

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #597.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use