VirtualBox

Ticket #2474 (closed defect: invalid)

Opened 5 years ago

Last modified 4 years ago

Host Interface Network Connection Deteriorates on Ubuntu Guest with Static IP on OpenSolaris Host.

Reported by: bleonard Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Linux
Host type: Solaris

Description

I have an OpenSolaris host, configured with static IP address 10.0.1.175, running Apache.

I have an Ubuntu 7.04 guest configured with host interface networking.

From Ubuntu, I can open Firefox and open a web page served from OpenSolaris. However, after a couple of page refreshes, the connection breaks, and Firefox returns with "Failed to Connect"

Even stranger is that the only way I know how to get the guest connection working again is to reboot the host (OpenSolaris). Presumably, there must be some zombie process I could restart to restore the connection, but even if so, it would only be temporary.

Note, this problem does seem to be guest specific, because the connection works fine for me from WindowsXP. I haven't yet tried any other guests, but I'm open to suggestions if some are some known to be more robust than others.

On the Ubuntu guest, the problem is easily repeatable. Note, this problem only occurs when OpenSolaris is configured with a static IP address. When OpenSolaris is configured with DHCP, everything works fine.

Nothing jumped out at me in the log, but it's attached.

Attachments

VBox.log Download (34.4 KB) - added by bleonard 5 years ago.
VirtualBox log file for Ubuntu Machine

Change History

Changed 5 years ago by bleonard

VirtualBox log file for Ubuntu Machine

comment:1 Changed 5 years ago by ramshankar

This problem of "stale" networking should be fixed in the next release (2.0.4). Thanks for the report.

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:3 Changed 5 years ago by bleonard

  • Status changed from closed to reopened
  • Resolution fixed deleted

Unfortunately, 2.04 does not fix this issue. I'm trying to launch a Java Web Start application hosted on OpenSolaris using either Ubuntu or Windows XP guests. In both cases the download fails, after which the network fails to work at all. This is easily reproducible. I'll even send you the application to test against (I don't see a way to attach another file to this bug though).

comment:4 Changed 5 years ago by ramshankar

Yes please attach the application (or if it's too big i.e. exceeding a couple of MB, please upload it on some free file hosting like yousendit.com and link back here). Also please give complete instructions on how to reproduce this problem (it will save me time).

comment:5 Changed 5 years ago by bleonard

Steps to produce:

1) Install OpenSolaris 2008.05

2) Install Apache

pkg install SUNWapch22

3) Start Apache

svcs enable apache22

4) Extract the following to /var/apache2/2.2/htdocs

 http://wikis.sun.com/download/attachments/47892868/htdocs.zip

5) Add the following to /etc/apache2/2.2/mime.types

application/x-java-jnlp-file                    jnlp

6) Configure OpenSolaris for Static IP. By default DHCP is used. Edit /etc/nwam/llp. It should look as follows:

<device> dhcp

Change that to:

<device> static 10.0.1.175

7) Unplug your network cable

8) Restart the network service

svcadm restart nwam

In a couple of seconds you should be notified that 10.0.1.175 is now your IP address.

9) Configure a VirtualBox guest with Host Interface networking.

10) Install the Java Runtime on the guest.

11) Start the guest and launch a browser. Browse to:

 http://10.0.1.175/launch.html

You should then be prompted to run the application using Java Web Start. The application will begin to download, but then the download will stall. At this time, all networking between the host and the guest will be lost.

If the download does succeed for you, the application will not actually run (it requires a database on the host). However, I have never been able to get past the download when using a static IP. It works when using DHCP.

That should cover it. If you run into any difficulties along the way, please let me know and I'll help you work through them.

Thanks, Brian

comment:6 Changed 5 years ago by frank

  • Component changed from network to network/hostif

comment:7 Changed 5 years ago by ramshankar

I can't seem to reproduce this with 2.1.0+. Namely I can access 10.0.1.175 from the guest (OpenSolaris 2008.11) and it brings up a page "Test page for launching the application via JNLP" and a "Launch the application!" link. Clicking the link opens '.jnlp' file in the browser.

Could you try this with 2.1.0 ?

comment:8 Changed 5 years ago by john.doe

i have the same symptom with an ubuntu 8.10 (64b) host and a win2k guest (migrated from a laptop). inside the guest i have mapped a samba share of the host. the host does nat with iptables. when i transfer bigger files (hundreds of MB) onto the samba share the connection is almost always lost after a few dozen MB (but i transfered a whole dvd image once ok). i was not able to recover from this failure without rebooting the guest, but i did not have to reboot the host (or do anything else in the host os).

i noticed this bug in 2.1.2 and 2.1.4 of the sun binaries (virtualbox-2.1_2.1.2-41885%5fUbuntu%5fintrepid_amd64, virtualbox-2.1_2.1.4-42893%5fUbuntu%5fintrepid_amd64).

comment:9 Changed 5 years ago by frank

John, to be sure: Are you using a host interface or NAT for the Samba mapping?

comment:10 Changed 5 years ago by john.doe

the iptables nat on the host is used to bring the guest into the internet. it is not used for the samba connection at all, i just thought i should mention it, sorry for the confusion.

im using the (new) host interface to communicate with the host. the ip im connecting to is an alias ip on the native host interface (setup by a call to "ip addr add 192.168.0.1/24 dev eth0" from the /etc/network/interfaces configuration). i.e. i have a public ip and the local/private alias on the same interface and iptables nats from the private to the public nat, if needed. but samba listens on the private interface and the guests connects there... so no natting in between.

hope its clear now :)

ps: i also noticed that im able to capture the host traffic inside the guest (with wireshark in promicuous mode). its quite logical... the host interface is a kind of soft ethernet bridge afaik. but it brings up some delicate security concerns (if you think about a windows machine, that gets infected and sniffs for network traffic. i think thats a quite plausible attack vector for unix workstations with windows guests). maybe this should be stated more clearly, when one enables host interfacing (imho it would be even better to filter out packages directed to the mac address of the native host interface). i did not look at documentation or code yet, it just came to my mind, when i read your question. sorry (again :) if thats already addressed somewhere.

comment:11 follow-up: ↓ 12 Changed 5 years ago by john.doe

hm i remember now why i mentioned iptables in the first place ;) because i dont lose connectivity when downloading from the nated internet (to the virtual hdd), although i get up to 1,5MB/s (16mbit downstream).

comment:12 in reply to: ↑ 11 Changed 5 years ago by john.doe

all my (john.doe) replies here are wrong, sorry! i need to reboot the _guest_ not the host. my problem seems to be #3318.

comment:13 Changed 5 years ago by ramshankar

  • Status changed from reopened to closed
  • Resolution set to invalid

Closing. Please reopen if there is a problem with 2.2.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use