VirtualBox

Ticket #247 (closed defect: duplicate)

Opened 7 years ago

Last modified 6 years ago

Virtual machine inaccessible (shared folder inaccessible)

Reported by: swolf Owned by:
Priority: major Component: VM control
Version: VirtualBox 1.3.8 Keywords: virtual machine inaccessible
Cc: Guest type: other
Host type: other

Description

I create a virtual machine (host and guest Linux Debian Etch, Kernel 2.6), take a few snapshots and all works fine. However, the machine becomes inaccessible and I get the following error:

Hard disk '/home/swolf/.VirtualBox/VDI/Debian-Etch.vdi' with UUID {e4d93397-e4de-4cb3-bb5b-52deb2ccb32e} is already attached to a machine with UUID {bdf8bcca-82db-4156-902a-0e9658db7b6c}

The hard disk with UUID {e4d93397-e4de-4cb3-bb5b-52deb2ccb32e} was created on creating of the virtual machine with UUID {bdf8bcca-82db-4156-902a-0e9658db7b6c} by using VirtualBox.

Attachments

VirtualBox.xml Download (2.7 KB) - added by swolf 7 years ago.
Debian (Etch).xml Download (7.8 KB) - added by swolf 7 years ago.

Change History

Changed 7 years ago by swolf

Changed 7 years ago by swolf

comment:1 Changed 7 years ago by sandervl73

Can you reproduce this and, if so, post a step by step description? You can try to discard the snapshots.

comment:2 follow-up: ↓ 3 Changed 7 years ago by qm

It happens if in the VM xml-config in the ANY "<SharedFolder hostPath="/bla/bla" name="bla"/> section hostPath is defined wrong or hostPath - symlink.

PS Sorry, I do not know english well.

comment:3 in reply to: ↑ 2 ; follow-up: ↓ 4 Changed 7 years ago by sandervl73

Replying to qm:

It happens if in the VM xml-config in the ANY "<SharedFolder hostPath="/bla/bla" name="bla"/> section hostPath is defined wrong or hostPath - symlink.

I've managed to reproduce this. We'll fix this. Thanks.

comment:4 in reply to: ↑ 3 ; follow-up: ↓ 5 Changed 7 years ago by michael003

This just happened to me using VirtualBox 1.5.0 in Ubuntu Gutsy. I fixed it by removing the symlinked shared folder and correcting shared folder paths. I also had to manually insert the snapshots back into VirtualBox.xml.

comment:5 in reply to: ↑ 4 Changed 6 years ago by maletin

Replying to michael003:

I fixed it by removing the symlinked shared folder and correcting shared folder paths. I also had to manually insert the snapshots back into VirtualBox.xml.

Can you write a HowTo to correct this problem?

comment:6 Changed 6 years ago by frank

  • Component changed from other to VM control
  • Summary changed from Virtual machine inaccessible to Virtual machine inaccessible (shared folder inaccessible)

comment:7 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #822.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use