VirtualBox

Ticket #2430 (closed defect: wontfix)

Opened 6 years ago

Last modified 4 years ago

GRUB entry for OpenSolaris disappears

Reported by: glynnfoster Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: other
Host type: Mac OS X

Description (last modified by frank) (diff)

This is a pretty regularly reproducible problem for running OpenSolaris on VirtualBox on MacOSX, though I'm unsure of the steps to reproduce it (possibly a hard reset)?

At some point, when I start the virtual machine (in this case one of the betas towards OpenSolaris 2008.11), I get to the empty GRUB screen ie. it can't find the configuration from the rpool. Typing in some of the grub commands, I get

grub> kernel$ /platform/i86pc/kernel/$ISADIR/unix -B $ZFS-BOOTFS
loading '/platform/i86pc/kernel/$ISADIR/unix -B $ZFS-BOOTFS'
cpu: 'GenuineIntel' family 6 model 7 step 6
amd64: CPU does NOT support long mode
amd64: CPU does NOT support PAE
amd64: CPU does NOT support amd64 executables

Error 18: Selected cylinder exceeds max supported by BIOS

One of the OpenSolaris engineers suggested this could be a VBox problem about not forcing the host to flush?

Attachments

virtual-box.log Download (57.8 KB) - added by glynnfoster 5 years ago.
Log file hopefully detailing what went wrong

Change History

comment:1 Changed 5 years ago by frank

  • Description modified (diff)

comment:2 Changed 5 years ago by frank

Please could you attach a VBox.log file from a session after you executed the above commands?

Changed 5 years ago by glynnfoster

Log file hopefully detailing what went wrong

comment:3 Changed 5 years ago by glynnfoster

I'm hoping the attached log is the one you want. I've got a newer log, but I think that doesn't show the cause of what happened, but simply a start and power off sequence that got me to the GRUB screen and no further.

comment:4 Changed 5 years ago by frank

Thanks. How big is your virtual disk exactly, that is, what did you specify during disk creation and how big (in bytes) is that file currently? And are you sure that your guest disk did not screw up the disk image somehow, that is, can you check the virtual disk image with an OpenSolaris tool for disk consistence?

comment:5 Changed 5 years ago by glynnfoster

The virtual disk is 30GB, with 1339 MB Base Memory, 64MB Video Memory.

Essentially the disk is showing up as corrupted, so this may be the main reason why it can't get the menu.lst.

I filed a bug against OpenSolaris here -

 http://defect.opensolaris.org/bz/show_bug.cgi?id=3965

The interesting thing now is what is causing it - is it a ZFS problem? or VirtualBox? Obviously when I hard reset my machine, it caused everything to suddenly die and potentially looks like this caused ZFS to have a corrupt image.

comment:6 Changed 5 years ago by glynnfoster

Managed to reproduce this. Looks like when I do a hard reset of OSX, and VB 2.0.2 with a build of OpenSolaris, the ZFS file system seems to corrupt and can't recover. Very frustrating.

comment:7 Changed 5 years ago by frank

Do I understand you correct, you hard reset your host and OpenSolaris guest is scrambled after that? If so I fear we can not much do about this ...

comment:8 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to wontfix
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use