VirtualBox

Ticket #2416 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

host networking is not working under osx

Reported by: mafubryan Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

There is a discussion in the forums relating to this topic.

 http://forums.virtualbox.org/viewtopic.php?t=9241

Basically, it doesn't do anything, no virtual interface is created on the OSX host (I checked using ifconfig).

When the virtual Ubuntu boots up ifconfig only displays the lo interface.

It would be cool if this option was disabled in the GUI as it would save people from trying to get it working.

Thanks Guys

Change History

comment:1 Changed 6 years ago by sandervl73

  • Priority changed from minor to major
  • Summary changed from host networking is not working under osx, please disable in GUI to host networking is not working under osx

You prefer us to disable instead of fixing it? Cool suggestion.

If you want to be helpful, why not include more information about your setup? It works fine here. And you're not supposed to see any virtual interface afaik.

comment:2 Changed 5 years ago by boecko

It doesn't work with all interfaces on my MacBook Pro (FirstGen) Ethernet

============= ======== ========= ============
Hostinterface ModeHost ModeGuest Status 
------------- -------- --------- ------------
ethernet      static   static    works
ethernet      dhcp     dhcp      works
airport       static   dhcp      noip
airport       dhcp     dhcp      noip
airport       dhcp     static    ping timeout
airport       static   static    sometimes
============= ======== ========= ============

I've tried it on the internal airport and a RaLink-Wireless-N-Cardbus-Card. Same sympthoms.

comment:3 Changed 5 years ago by boecko

I forgot to mention two things:

  1. VirtualBox 2.0.4
  1. With a static Guest-IP, i'm able to ping the IP of the hostinterface, nothing else

comment:4 Changed 5 years ago by cyberpunk

This works non-deterministically for me. Also, if / when host networking stops work, NAT stops working as well. This is on vbox 2.0.4 and OS X 10.5.5 on a macbook pro. Using the Intel Server NIC / ethernet host NIC seems to be more reliable for me.

(Also, sorry I didn't feel like making a real acct to post with.)

comment:5 Changed 5 years ago by ncsutmf

Using VirtualBox 2.0.4 on OS X 10.5.5 host

The host interface networking works the first time. As soon as the VM reboots, it stops working. Have even tried setting an IP address manually instead of using DHCP and it did not work. Have to shut the VM down, quit VirtualBox, restart VirtualBox, restart VM and it works again.

Guest OS is Windows XP, although it also was able to PXE boot into SuSE Linux to clone an image to the virtual hard disk. When it is working I can ping the VM from an external machine that is on the same subnet.

I have been able to reproduce this behavior consistently about 4 times now with this VM.

comment:6 Changed 5 years ago by ncsutmf

More information:  Adapter 1 Intel PRO/1000 MT Desktop (host interface, en0: Built-in Ethernet)

comment:7 Changed 5 years ago by dmyurych

Just to add my own voice to clear up how Host Interface Networking is even
supposed to work on OSX:

From the VirtualBox user manual:

6.5 Introduction to Host Interface Networking (HIF)          

With Host Interface Networking, VirtualBox creates a new networking interface
in software on the host computer. This new software interface will then exist
in parallel to your regular interfaces (e.g., on a Linux host vbox0 will exist
alongside eth0).  When a guest is using such a new software interface, it looks
to the host system as though the guest were physically connected to the 
interface using a network cable: the host can send data to the guest through 
that interface and receive data from it. This means that you can set up routing
or bridging between the guest and the rest of your network.

Yet as others have pointed out in the forums and I have noticed as well, this does
not seem to be the case under OSX. No new networking interfaces ever come into
existence when using Host Interface Networking.

Later on in the user manual it states:

6.7 Host Interface Networking on Mac OS X hosts 

On Mac OS X, configuring Host Interface Networking is extremely simple. 
All you need to do is to open the Settings dialog of a virtual machine, go 
to the “Network” page and select “Host Interface” in the drop down list 
for the “Attached to” field. Finally, select desired host interface from 
the list at the bottom of the page, which contains the physical network 
interfaces of your systems.

Huh? Made extremely simple but it seems to go against the original intent of Host
Interface Networking. What they have really done is implement transparent network
bridging and from this bug and what people have been writing in the forums, it doesn't
appear to be working all that well either.

What this also does is eliminate a whole set of functionality that is available under
the Linux and Windows versions. Not everyone wants to use Host Interfacing Networking
for just network bridging. In my case, all I want is to use the new interface to setup
a server on the client that only needs to communicate directly with the host and not
over the rest of the network.

If they would just implement this feature the same way as on Linux and Windows by
creating a new network interface, then people could just as easily implement
network bridging by using Apple's built-in internet sharing tool which may go along
way toward eliminating the problems people are having getting it to work as is.

However if I'm completely misinformed on this someone please let me know otherwise.
Thanks,

--
Darrel Yurychuk

comment:8 Changed 5 years ago by mschout

This is fixed (for me at least) in VirtualBox 2.1.0

comment:9 Changed 5 years ago by marxist

it is not fixed for me (using airport. haven't tested with ethernet):

i've installed debian linux in virtualbox 2.1 on mac os x 10.5.6. with nat networking everything works fine. when i switch to bridged network (host controller -> airport), both my network connections in linux and mac os x stop working.

the interessting part is, that the linux client does get an ip (my local network uses the 192.168.5.x range), e.g.: 192.168.5.71. routes and resolve.conf look fine (router and dns is: 192.168.5.11). with the newest version of virtualbox the client's network works for a short time (was able to install openssh-server), but stops then (pinging the router gives "destination host unreachable"). unfortunatly networking on my mac ox x host then stops working, too!! no dns resolution, nothing. i have to reboot to get it working again. closing virtualbox is not sufficient.

comment:10 Changed 5 years ago by frank

  • Component changed from network to network/hostif

comment:11 Changed 5 years ago by joshmoore

+1 same issue with Mac 10.4, vbox 2.1.2 and Debian 4.0

comment:12 Changed 5 years ago by jrose

Here's another forum thread, which I contributed to before going in search of this bug:

 http://forums.virtualbox.org/viewtopic.php?p=58322

Like others, all I want is host-to-guest networking, with static IP addresses on a private 1-1 network. Hopefully this will be a simple check-box item in the GUI, some day soon. Without it, I can't rig stable NFS and SSH connections between the host and guest.

comment:13 Changed 5 years ago by kiddyr

Me too. Me three. Can we vote for this bug?

I am on Mac OS X 10.5.6 and am using clients configured with Ubuntu 8.10. I would _really_ like to stop using Parallels. However, I do want to be able to ssh from my host to my guest instances. After all, if all I want to do is command-line, why should I need to run the terminal app on the guest? Terminal on the host works well, I can cut-and-paste and all that.

comment:14 Changed 5 years ago by andrew.sharpe.7.9

Another vote. Workaround indicated in  http://forums.virtualbox.org/viewtopic.php?t=11653 works.

comment:15 Changed 5 years ago by frank

You might want to try out VirtualBox 2.2.0 Beta 2 which introduces host-only networking including a DHCP server.

comment:16 Changed 5 years ago by boecko

Bridged Networking works in VirtualBox 2.2.0 Beta 2 ! Tried with Airport and DHCP

comment:17 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if this bug persists with VirtualBox 3.0.10.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use