VirtualBox

Ticket #2413 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

[Linux] Shared Folders to symlink

Reported by: Sasquatch Owned by:
Priority: minor Component: shared folders
Version: VirtualBox 3.2.6 Keywords:
Cc: Guest type: other
Host type: Linux

Description

When creating a Shared Folder to a symbolic link, it will give an error that the path is not obsolute. Pointing it to a normal folder does not give this error.

The reason I want this, is because all my VMs are on an external hard drive. It works just fine when I swap them from my PC to my laptop, and the paths are the same too. Just the Shared Folders are a bit different. Where my internal hard drive is mounted to /data on my laptop, on my PC it's mounted in /media/data with a symlink /data to it.
For now, I will change the mount point on my laptop to /media, creating the same situation as on my PC, but this should be looked at.

Change History

comment:1 Changed 4 years ago by Technologov

Duplicate of Wish #818

-Technologov

comment:2 Changed 4 years ago by frank

  • Version changed from VirtualBox 2.0.2 to VirtualBox 3.2.6

I disagree. This is not about symbolic links in shared folders.

comment:3 Changed 4 years ago by Sasquatch

I don't use this set up since the report, but I just checked, and it no longer is a problem. Somewhere between all the bug fixes and changes to the shared folder functionality, probably when the symlink in a shared folder was broken then fixed again, this got fixed too.

Problem exists in 2.x, no longer exists on 3.2.6. The exact version number of when it was fixed is unknown.

comment:4 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use