VirtualBox

Ticket #241 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

DOSBox emulator crashes in VirtualBox

Reported by: Technologov Owned by:
Priority: major Component: other
Version: VirtualBox 1.4.0 Keywords:
Cc: Guest type: other
Host type: other

Description

hi all !

I wanna make sure one kind of Box works in the other one :)

OK, lets be a bit more serious:

-DOSBox, a 32-bit usermode application crashes in VirtualBox.

It doesn't crash when run natively (without VirtualBox). It uses Simple DirectMedia Layer (SDL) for 2D rendering.

System: Windows XP host, XP guest, DOSBox 0.70, VirtualBox 1.3.8

-Alexey "Technologov"

Change History

comment:1 Changed 7 years ago by Technologov

BTW: Running on Windows XP host, but openSUSE 10.2 guest *works*!

comment:2 Changed 7 years ago by sandervl73

Probably due to the ntvdm instability. (fixed in SVN)

comment:3 Changed 7 years ago by sandervl73

  • Priority changed from critical to major

comment:4 Changed 7 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Try again with 1.4.0 and reopen if it still happens.

comment:5 Changed 7 years ago by Technologov

  • Status changed from closed to reopened
  • Resolution fixed deleted

Yes, it still crashes. DOSbox 0.70.

Tested on: Win Vista, VBox 1.4.0

comment:6 Changed 7 years ago by frank

  • Version changed from VirtualBox 1.3.8 to VirtualBox 1.4.0

comment:7 Changed 7 years ago by Technologov

Please pay attention: DOSbox is _not_ 16-bit application.

It is a 32-bit application, that runs fine under Linux guest, but crashes under Windows guest. On native hardware, DOSbox works perfectly on both Windows and Linux.

Please fix VirtualBox.

comment:8 Changed 7 years ago by c2woody

This is (most likely) a bug in DOSBox, it's already fixed and should work in the next version. You can try setting SDL_VIDEODRIVER=windib before starting DOSBox to work around this, maybe you can report back if it works for you that way because I didn't perform any testing.

The information was already sent to the VirtualBox contact address but there was no reply, so I'm posting it here as well.

comment:9 follow-up: ↓ 10 Changed 7 years ago by Technologov

Do you realize that instead of rendering to SDL, it will render to Windows bitmap ?

Which means, that even if this works, it will be slower than SDL.

Since DOSbox runs fine on normal Windows, but crashes on VirtualBox, the bug is in VirtualBox. Changing rendering target is no more than cheap dirty workaround trick.

Thanks for idea anyway. I'll try this workaround, when I return Home.

-Technologov

comment:10 in reply to: ↑ 9 Changed 7 years ago by achimha

Since DOSbox runs fine on normal Windows, but crashes on VirtualBox, the bug is in VirtualBox. Changing rendering target is no more than cheap dirty workaround trick.

This is a rather incompetent statement.

comment:11 Changed 7 years ago by sandervl73

I know it's hard to comprehend, but if DOSBox crashes because no DirectDraw support is available, then it's not VBox's fault.

comment:12 Changed 7 years ago by c2woody

Do you realize that instead of rendering to SDL, it will render to Windows bitmap ?

Maybe check the SDL sources to see how this works.

As noted above it is NOT a bug in VirtualBox but in the code that (should) automatically uses windib if directx is not available to DOSBox.

comment:13 Changed 7 years ago by Technologov

to c2woody:

Fantastic ! You were right ! DOSbox really crashes because of lack of DirectDraw support. So yes, this is definitely a DOSbox bug.

Sorry all the people. c2woody: Thanks a lot !

-Technologov

comment:14 Changed 7 years ago by Technologov

Please close this bug.

comment:15 Changed 7 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to invalid

comment:16 Changed 7 years ago by Technologov

Fix verified. DOSbox 0.71 doesn't crashes anymore.

-Technologov

comment:17 Changed 7 years ago by Technologov

  • Status changed from closed to reopened
  • Resolution invalid deleted

Unfortunately, I'm forced to reopen this bug. 1.5.0 contains incomplete DirectDraw drivers, that makes DOSbox crash again.

Workaround: disable DirectDraw acceleration in Windows XP guest. This makes DOSbox use windib backend.

Host: Windows XP, DOSbox 0.71, VirtualBox 1.5.0.

-Technologov. 01.Oct.2007.

comment:18 Changed 6 years ago by Technologov

This is fixed now in 1.5.2.

-Technologov

comment:19 Changed 6 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use