VirtualBox

Ticket #2408 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Problems with USB on Windows Host (XP and Vista)

Reported by: xfernandez Owned by:
Priority: critical Component: USB
Version: VirtualBox 2.0.2 Keywords: USB, busy
Cc: Guest type: Linux
Host type: Windows

Description

I started with only 1 Gigabyte of RAM on the host system (Windows Vista). With this amount of RAM:

· VirtualBox can start the VM · It seems impossible to control USB devices (in general, not just the IO card) · The system becomes very slow and is likely to hang after awhile

I added 1 Gigabyte of RAM to the system and noticed improvements: · The system does not become slow nor hang. · I was able to access a pen drive and a standard Bluetooth dongle from the VM with no problems. · I was able to access the IO card with problems (described below).

It's necessary to have 2 Giga of Ram in the Host?

In the probes I use an IOCard that it's connected via USB. This IOCard has 3 bluetooth devices. This 3 devices are detected on USB filter creation. And I only connect the IOCard when the VM is running. In general the VM detects the bluetooth USB devices (My guest is a Linux and I use the hciconfig command).

But In some cases, it appears problems: · Sometimes appears the error: "USB device is busy with a previous request, please try again" Result Code: E_INVALIDARG (0x80070057) · Simetimes VM detects 3 devices, other times 2 devices, 1 device, 0... I can't understand the behavior.

If you need more information, no doubt of ask me.

Change History

comment:1 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 3.2.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use