VirtualBox

Ticket #2403 (closed enhancement: duplicate)

Opened 6 years ago

Last modified 6 years ago

Shared Folder speed with DC++ on Virtual box is 2 to 3 times slower than DC++ on Parallels

Reported by: b1ll Owned by:
Priority: minor Component: shared folders
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

Since trying to move from Parallels to Virtualbox, I thought I was experiencing slower io performance with Virtualbox. I couldn't find a generic free io test, so I setup a small test using bcdc++. My test uses about 200 files at between 200 and 350MB, plus a similar amount of of small files at 200-600kb, all located in a single directory.

I have timed indexing this directory of random binary files using DC++ on XP with Virtualbox and Parallels. Parallels is always 2 to 3 times faster than Virtualbox. The files that are being indexed, are on a ZFS volume. The files are accessed by a single mount of root file system exposed to Parallels and Virtualbox. "/" is mounted as drive Z. So bcdc++ accesses the directory as such, Z:\Volumes\<zfs volume name>\<zfs directory>

bcdc++ can be found here(I use 0.699d binaries):  http://utrum.dyndns.org:8000/index.html zfs is here(I use 119 binaries):  http://zfs.macosforge.org/trac/wiki/downloads both of these apps have source available. It would be nice if Virtualbox could be at least as speedy as Parallels.

Change History

comment:1 follow-up: ↓ 2 Changed 6 years ago by frank

Just to be sure: You have mounted the ZFS file system natively to your Mac OS X host and mounted that directory to the Windows XP guest running on VirtualBox using shared folders, right?

comment:2 in reply to: ↑ 1 Changed 6 years ago by b1ll

Replying to frank:

Just to be sure: You have mounted the ZFS file system natively to your Mac OS X host and mounted that directory to the Windows XP guest running on VirtualBox using shared folders, right?

Yes, the zfs volume is mounted natively and the access is via shared folders.

comment:3 Changed 6 years ago by sandervl73

  • Summary changed from IO Speed with DC++ on Virtual box is 2 to 3 times slower than DC++ on Parallels to Shared Folder speed with DC++ on Virtual box is 2 to 3 times slower than DC++ on Parallels

comment:4 follow-up: ↓ 5 Changed 6 years ago by sandervl73

Duplicate of #1728. Could you check the update there to see if there's any improvement in your case? (I'll leave this one open for now)

comment:5 in reply to: ↑ 4 ; follow-up: ↓ 6 Changed 6 years ago by b1ll

Replying to sandervl73:

Duplicate of #1728. Could you check the update there to see if there's any improvement in your case? (I'll leave this one open for now)

At first blush, there seems to be an improvement after updating vboxMRXNP.dll. I ran my test for a a few moments and it appears to be as fast as Parallels now. A complete run takes about an hour on Parallels. I will update this ticket later today.

comment:6 in reply to: ↑ 5 Changed 6 years ago by b1ll

Replying to b1ll:

Replying to sandervl73:

Duplicate of #1728. Could you check the update there to see if there's any improvement in your case? (I'll leave this one open for now)

At first blush, there seems to be an improvement after updating vboxMRXNP.dll. I ran my test for a a few moments and it appears to be as fast as Parallels now. A complete run takes about an hour on Parallels. I will update this ticket later today.

The replacement "vboxMRXNP.dll" does indeed solve the speed issue I was experiencing. Thanks.

comment:7 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use