VirtualBox

Ticket #2380 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

VirtualBox 2.0.2 GUI hangs / stops responding to input

Reported by: myxiplx Owned by:
Priority: major Component: VMM
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: other
Host type: other

Description

Over the past few days I've noticed that the VirtualBox virtual machine window will stop responding to input for several minutes, although the virtual machine can be seen to be running fine.

I can't find any bugs similar to this on the tracker, but it appears I'm not the only person noticing this as I found this post in the forums:  http://forums.virtualbox.org/viewtopic.php?p=40763#40763

I'm noticing the problem at least once a day at the moment, but can't yet see any pattern as to when this happens.

Change History

comment:1 Changed 6 years ago by myxiplx

I believe I've just this second seen the bug as it starts. It looks like the input isn't stopping completely, but may be just slowing down to the extent it's unusable.

The bug this time started while I was typing within the virtual machine, it suddenly slowed down, and was taking 1-3 seconds for each character to appear. This went on for the 25 or so characters that were still in the keyboard buffer, and the system then became unresponsive to mouse commands or keystrokes for a further minute or so.

The whole time this was going on, a network file copy operation running in the background was progressing at what appeared to be normal speed, with filenames scrolling past faster than the eye can follow.

As before, after a minute or so the system recovered and I'm now able to use it normally.

comment:2 Changed 6 years ago by myxiplx

I have more details to add now. I've seen a virtual machine GUI hang for several hours now, with no way I can find to recover it via the virtualbox interface. It doesn't even respond to the host key any more.

I have however found that accessing the hosted machine via RDP seems to let it recover from this. I'm not connecting to Virtual Box' RDP interface here, I'm connecting to the Windows RDP in the guest machine.

Once I'm connected over RDP, windows locks the local console and I can see that in the VirtualBox GUI. When I disconnect RDP, host+del allows me to unlock the console and the virtualbox interface is now working properly again.

It's locking up several times a day for me at the moment, most often when I run a program called Dameware Mini Remote Control on my windows machine. It seems that connecting to a remote machine using Dameware is causing problems for VirtualBox.

comment:3 Changed 6 years ago by mamnmamn

Our experience of this bug is slightly different. Once the GUI around the virtual machine dies we can not recover it through connecting through windows RDP. So far, the only way the GUI comes back to life is to shutdown the virtual machine (XP) and then restart it.

What we have found is that even though it looks like the virtual XP machine looks like it is not responding, it is buy just not showing the mouse cursor. The cursor is hidden but working. The keyboard is working as well.

comment:4 Changed 5 years ago by djfarid

I can confirm the Dameware+VirtualBox problem. Whenever I connect to a machine with Dameware the GUI gets very very sluggish or stops responding completely. The weird thing is that the exact same thing happens in either these two cases: 1. I start VirtualBox. Open my Windows XP machine. In that Windows XP machine, I start my VPN-connection to the LAN at my work. In that Windows XP machine, I start Dameware. Connect to a Windows sever 2003 machine with Dameware. VirtualBox stops responding completely.

2. I start VirtualBox. Open my Windows XP machine. In that Windows XP machine, I start my VPN-connection to the LAN at my work. Then start RDP to a Windows XP machine at work. Then start Dameware IN THAT WINDOWS XP MACHINE AT WORK. Connect to a Windows server 2003 machine with Dameware with that instance on the remote computer. VirtualBox stops responding completely.

If I sit on this remote XP computer at work, there are no problems at all running Dameware.

When this happens, I am able to move the mouse cursor but the machine is not responding. Sorry if this is not the exact same bug.

comment:5 Changed 5 years ago by frank

  • Component changed from other to VMM

Please attach a VBox.log file of such a hanging session.

comment:6 Changed 5 years ago by myxiplx

Ok, this is improved in 2.1.0, but still present. I noticed another problem with Dameware slowing the computer down, and I'm now having to run Dameware in much slower windows.

It looks to me like it might be a graphics bottleneck, I'm certainly seeing no performance issues with CPU, memory or disk. Is there any way at all to troubleshoot or benchmark graphics performance?

My latest comments are posted here:  http://forums.virtualbox.org/viewtopic.php?t=13500

I've also just had my virtualbox guest crash, and think that might also be related to dameware. Filing a bug on the crash now.

comment:7 Changed 5 years ago by myxiplx

Bleh, first paragraph of my last post has a typo, should have read:

"I'm now having to run Dameware in much smaller windows."

comment:8 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Pleas reopen if still relevant with VBox 3.1.6. In that case please attach a VBox.log file of a VBox 3.1.6 session.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use