VirtualBox

Ticket #2375 (closed task: wontfix)

Opened 6 years ago

Last modified 4 years ago

Let everyone edit the wiki

Reported by: jasonspiro2 Owned by:
Priority: major Component: documentation
Version: VirtualBox 2.0.2 Keywords: wiki
Cc: Guest type: other
Host type: other

Description

A request

Please allow all registered Trac users to edit the VirtualBox wiki. Here is how I suggest you do this:

  1. First, resolve ticket #2365 by releasing your wiki contents under a GPL and GFDL dual license. You should do that first before allowing free wiki editing. This is because the greater the number of people who already have contributed to the wiki, the more work it is to do the relicensing.
  2. Then, edit your trac.ini file to give all users the WIKI_MODIFY Trac privilege.

Why you should do this

  1. The wiki will fill up with lots more info. This will give VBox an advantage over the competition: it will have a more-useful wiki.
  2. Also, Innotek employees can spend less time on the wiki and more time coding, because users can help manage the wiki.

Change History

comment:1 Changed 6 years ago by frank

Of course it would be cool if users could help manage the Wiki. The drawback is that Sun is still responsible for the content. A malicious user could put some unwanted content into the Wiki. I think, the effort for periodically checks for unwanted changes (at least once per day) would be too high.

comment:2 Changed 6 years ago by jasonspiro2

I volunteer to periodically check for unwanted changes for at least the first week that free editing is enabled. If I have time, maybe I will check for longer.

Frank, want me to find some additional volunteers who will also help with timeline patrol (recent changes patrol)?

comment:3 Changed 6 years ago by frank

That is a great offer, thank you! The problem is that Sun is still responsible for the content of these web pages, therefore Sun needs some legal guarantee. Which is only possible if only Sun employees have write access to the Wiki.

comment:4 Changed 6 years ago by jasonspiro2

How about one of these ideas?:

Best idea: Add disclaimers at the bottom of every page ( like the disclaimers at the bottom of  http://wikis.sun.com/display/Help/Granting+Write+Access+by+Modifying+Space+Permissions ) then let everyone edit the wiki.

I will help patrol for the first week if you would like me to. See how it goes. If you run into huge spam problems, then either install some Trac anti spam solution or switch to a different system. But try it out first and see how it goes.

Quite good idea: Disable edits to the really important pages, like the homepage and the download page. Then let everyone else edit the entire rest of the wiki.

Good idea: Write code to let users edit the wiki; but their changes are only shown to logged-in users until you approve the edits.

OK idea: Let only users who request wiki-edit permissions from you to edit the wiki.

No matter which idea you choose, you will get lots more edits.

comment:5 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to wontfix

We will not do this. There was a test setup for some time and it turned out that this Wiki was flooded by SPAM.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use