VirtualBox

Ticket #2367 (closed defect: fixed)

Opened 6 years ago

Last modified 3 years ago

Client display does not refresh when switching desktops on host

Reported by: rlk Owned by:
Priority: minor Component: GUI
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Solaris
Host type: Linux

Description

Running xorg 7.3 on OpenSUSE 11.0 (host), my OpenSolaris (currently onnv_98, but this predates it) guest does not redraw if I switch to a different host-side virtual desktop (host is using KDE 3.5.10) and back. I have to force a redisplay in order to get redraw. I am using the Guest Extensions in Solaris.

To reproduce (there are plenty of other ways to do this):

1) Boot OpenSolaris guest.

2) When the guest starts X and displays the crosshatch pattern, but

before the login screen is displayed, switch virtual desktops on the host.

3) Wait about 30 seconds.

4) Switch back to the virtual desktop containing the guest.

At this point, I see a blank display (usually just a dull blue). If I move my mouse over where the login box, or where one of the buttons would be, or start typing my username, the corresponding GUI element does refresh.

Attachments

xorg.conf Download (8.4 KB) - added by rlk 6 years ago.
Host xorg.conf

Change History

Changed 6 years ago by rlk

Host xorg.conf

comment:1 Changed 6 years ago by rlk

Turning off backing store on the host seems to work around this problem. Backing store is generally desirable for performance reasons, though.

--- xorg.conf.xorg73    2008-09-27 14:05:07.000000000 -0400
+++ xorg.conf   2008-10-03 11:10:18.000000000 -0400
@@ -181,7 +181,7 @@
   Identifier   "Device[0]"
   Option       "monitor-VGA_1" "Monitor[0]"
   VendorName   "ATI"
-  Option       "BackingStore"  "on"
+#  Option       "BackingStore" "on"
 #  Option       "DRI"
 EndSection

comment:2 Changed 5 years ago by rlk

Confirmed that this issue still exists in 2.1.0.

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still reproducible with VBox 4.0.4 (actually the bug is probably fixed since VBox 3).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use