VirtualBox

Ticket #235 (closed defect: invalid)

Opened 7 years ago

Last modified 7 years ago

virtual Harddrive not writeble

Reported by: Gans100 Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.8 Keywords:
Cc: Guest type: other
Host type: other

Description

Hello everybody, i habe a big problem with your newest Version of VirtualBox!!! I cant write by an installation to the virtual Harddrive. I becam everitimes an Error she sas that the Partitions not can be made et the virtual Drive. The Installationruntimes cant write to the virtual Drive. I have this Problem at the Linux Version ( Suse Linux 10.2 32 bit ) and at the Windosw Version ( Windows Vista 32 bit ). Whith the old Version of VirtualBox ( 1.3.6 ) it's all ok and the Instalationruntimes can write to the virtual Harddrives wihtout problems.

Sorry for my bad English, i'm from Germany

Bye Bjoern Schneegans

Attachments

Ubuntu_Linux.xml Download (2.1 KB) - added by Francois_Sabot 7 years ago.
XML file requestd
VBox.log Download (31.5 KB) - added by Francois_Sabot 7 years ago.
Sorry, here is the log file :s

Change History

comment:1 Changed 7 years ago by Francois_Sabot

I have the same problem with the version 1.3.8 under XP32-bits. And even a regression to 1.3.6 does not resolve the trouble here :s I've tried 3 different linux solutions, none of them can correctly perform the partition (ext3 is not 'writable')

Francois Sabot

comment:2 in reply to: ↑ description Changed 7 years ago by Francois_Sabot

I have the same problem with the version 1.3.8 under XP32-bits. And even a regression to 1.3.6 does not resolve the trouble here :s I've tried 3 different linux solutions, none of them can correctly perform the partition (ext3 is not 'writable')

Francois Sabot

Replying to Gans100:

Hello everybody, i habe a big problem with your newest Version of VirtualBox!!! I cant write by an installation to the virtual Harddrive. I becam everitimes an Error she sas that the Partitions not can be made et the virtual Drive. The Installationruntimes cant write to the virtual Drive. I have this Problem at the Linux Version ( Suse Linux 10.2 32 bit ) and at the Windosw Version ( Windows Vista 32 bit ). Whith the old Version of VirtualBox ( 1.3.6 ) it's all ok and the Instalationruntimes can write to the virtual Harddrives wihtout problems.

Sorry for my bad English, i'm from Germany

Bye Bjoern Schneegans

comment:3 follow-up: ↓ 4 Changed 7 years ago by klaus

Can you please attach the release log produced after a VBox run where this error occurred, the VM config and the VirtualBox config? The VirtualBox config is in ~/.VirtualBox/VirtualBox.xml, the VM config is in ~/.VirtualBox/VMNAME/VMNAME.xml and the release log is in ~/.VirtualBox/VMNAME/Logs/VBox.log. ~ corresponds to the user's home directory.

To me it appears that you either have a garbled VDI file (did you place it on a FAT32 partition?) or some misconfiguration.

Changed 7 years ago by Francois_Sabot

XML file requestd

comment:4 in reply to: ↑ 3 Changed 7 years ago by Francois_Sabot

Here it is. Everything was Ok until I installed the last version :s. And I recreate 3 times the VDI files, and re-installed properly after correct de-installation

Replying to klaus:

Can you please attach the release log produced after a VBox run where this error occurred, the VM config and the VirtualBox config? The VirtualBox config is in ~/.VirtualBox/VirtualBox.xml, the VM config is in ~/.VirtualBox/VMNAME/VMNAME.xml and the release log is in ~/.VirtualBox/VMNAME/Logs/VBox.log. ~ corresponds to the user's home directory.

To me it appears that you either have a garbled VDI file (did you place it on a FAT32 partition?) or some misconfiguration.

comment:5 follow-up: ↓ 6 Changed 7 years ago by klaus

The file you attached looks correct, but I requested two more files (and I'm sorry about the typo, the release log and the VM config file is in ~/.VirtualBox/Machines/...). Please attach them, too, because they contain the main information (a VM config file just refers to the disk config in VirtualBox.xml).

Changed 7 years ago by Francois_Sabot

Sorry, here is the log file :s

comment:6 in reply to: ↑ 5 Changed 7 years ago by Francois_Sabot

By the way I forget to say that all the host HD are on NTFS (but is doesn't seem to be a problem before)

Replying to klaus:

The file you attached looks correct, but I requested two more files (and I'm sorry about the typo, the release log and the VM config file is in ~/.VirtualBox/Machines/...). Please attach them, too, because they contain the main information (a VM config file just refers to the disk config in VirtualBox.xml).

comment:7 follow-up: ↓ 8 Changed 7 years ago by klaus

OK, the release log shows clearly that there's something odd happening on the virtual disk (actually the virtual IDE controller). The guest times out an IDE command. This usually happens if a read or write command on the host takes too long. Which can in the guest (depending on the mount options) cause a filesystem to be mounted as readonly.

Now the question is why do file read or write operations take excessively long on your host? Do you have the VDI in a compressed/encrypted NTFS file? VirtualBox transfers at most 64K in one operation and the timeout for each access is usually (depending on the guest) around 30 seconds. This deadline is never exceeded on the systems I have access to (all host filesystem reads/writes complete in at most a few seconds)...

Short summary: it appears to be a host OS problem.

comment:8 in reply to: ↑ 7 ; follow-up: ↓ 9 Changed 7 years ago by Francois_Sabot

The disks are not encrypted, but they are basic NTFS. I tested putting the VM and VDI on two differents SATA2 physical HDD, and each time I have the same trouble... The configuration is exactly the same as before, but I cannot create the same VM as I did 1 month ago - Perhaps a WinXP update putting the mess ? Francois

Replying to klaus:

OK, the release log shows clearly that there's something odd happening on the virtual disk (actually the virtual IDE controller). The guest times out an IDE command. This usually happens if a read or write command on the host takes too long. Which can in the guest (depending on the mount options) cause a filesystem to be mounted as readonly.

Now the question is why do file read or write operations take excessively long on your host? Do you have the VDI in a compressed/encrypted NTFS file? VirtualBox transfers at most 64K in one operation and the timeout for each access is usually (depending on the guest) around 30 seconds. This deadline is never exceeded on the systems I have access to (all host filesystem reads/writes complete in at most a few seconds)...

Short summary: it appears to be a host OS problem.

comment:9 in reply to: ↑ 8 Changed 7 years ago by p_garyali

I have absolutely the same problem. I have a SONY VAIO Window XP Home with a single 60 GB NTFS partition. I used Partition magic to create a separate 30 gig NTFS partition to be dedicated for Virtual Box. I tried to install Kubutu 6.10 Edgy and ran into the same problem which resulted in creating (and deleting) the VDIs five times and then at last giving it all up.

At my workplace I have the same setup running absolutely fine out of a partition that is FAT32!

Is it really an NTFS Vs FAT problem?

  • Gary

Replying to Francois_Sabot:

The disks are not encrypted, but they are basic NTFS. I tested putting the VM and VDI on two differents SATA2 physical HDD, and each time I have the same trouble... The configuration is exactly the same as before, but I cannot create the same VM as I did 1 month ago - Perhaps a WinXP update putting the mess ? Francois

Replying to klaus:

OK, the release log shows clearly that there's something odd happening on the virtual disk (actually the virtual IDE controller). The guest times out an IDE command. This usually happens if a read or write command on the host takes too long. Which can in the guest (depending on the mount options) cause a filesystem to be mounted as readonly.

Now the question is why do file read or write operations take excessively long on your host? Do you have the VDI in a compressed/encrypted NTFS file? VirtualBox transfers at most 64K in one operation and the timeout for each access is usually (depending on the guest) around 30 seconds. This deadline is never exceeded on the systems I have access to (all host filesystem reads/writes complete in at most a few seconds)...

Short summary: it appears to be a host OS problem.

comment:10 Changed 7 years ago by Kr1ll1n

I am having the same problem. With 1.3.4 I was able to write and create any virtual partitions, on either my main (80Gb NTFS) or my storage (300Gb NTFS) host hard drives. Went to 1.3.8, and could not format\partition virtual disks. tried to migrate back down to 1.3.4, but problem still persists. I hate to point this out, but there are 2 common denominators..... NTFS, and VirtualBox.... So I sincerely doubt it is a Host OS issue.....

comment:11 Changed 7 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to invalid

Try again with 1.4.0, but I'm reluctant to put the blame on VBox. There are known problems with NTFS partitions in Linux hosts. It seems to me the file system driver is simply not stable.

I have read other reports where installation of guest OSes failed with a fixed vdi container, but succeeded with a dynamic one. (again NTFS host partition)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use