VirtualBox

Ticket #2347 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

keyboard layout problem under ubuntu intrepid

Reported by: nemolivier Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.2 Keywords: keyboard layout
Cc: Guest type: other
Host type: other

Description

Hello, I have a problem with my keybord, instead of azerty, it produce on the first line : ge:q In the log I can see :

Failed to recognize the keyboard mapping or to guess it based on
00:00:36.804 the keyboard layout.

under ubuntu intrepid-ibex.

I had this problem under ubuntu hardy with virtual box 1.5:3, the 2.0.2 from other sources solved it.

Testing intrepid ibex (i totally removed the old virtual box package and use the one from intrepid) the problem came back. My keyboard is a Typematrix 2030 ps2. Work well under linux. I tried with another keybord and solve the problem (but I way prefer my true ergonomic keyboard).

I tried to change the keyboard settings from « evdev » to « PC104 keys » or « generic ACPI » with no results.

Same with other keyboard but I find a « trick » : I unpluged/repluged the keyboard, edev don’t recognise it and it works (but i loose my french settings in gnome !).

So I don’t know if it’s an ubuntu bug or a virtual box one…

Regards.

Attachments

vboxkeyboard.tar.gz Download (36.4 KB) - added by michael 6 years ago.
Updated VirtualBox keyboard handler
jm_vbox.log Download (42.9 KB) - added by jmason 5 years ago.
vbox.log from IE keyboard

Change History

comment:1 Changed 6 years ago by michael

This is almost certainly due to a bug which slipped into 2.0.2. If you are feeling adventurous, you can rebuild the VirtualBox keyboard handler (sources of the current version attached) and replace the one you have installed with the new version.

Changed 6 years ago by michael

Updated VirtualBox keyboard handler

comment:2 Changed 6 years ago by nemolivier

Of course, I am aventurous, so I compiled it and put the VBoxKeybord.so in /usr/lib/virtualbox/ I don’t know if works because one stroke kill the VM :D

Anyways the fact that when I « force » gnome (xorg ?) not to setup the layout it works.

comment:3 Changed 5 years ago by rhertzog

nemolivier like me uses a new Dvorak based layout known as "French Bépo" ( http://download.tuxfamily.org/dvorak/xkb/fr-dvorak-bepo-xkb-1.0rc2.tgz). I also had the same problem with VirtualBox 1.5.6 and I upgraded to 2.0.6 and my problem is gone (but the log still complains that it doesn't know of the keyboard mapping).

It is also probably a duplicate of #2052. I'm using debian sid with xorg 7.4 from Debian experimental and external Azerty keyboard. It looks like the guesses are better in this version if it can't identify the keyboard mapping.

comment:4 Changed 5 years ago by michael

VirtualBox currently uses two different heuristics to guess the keyboard layout, and will print information to the log if either of them fail. However, if this layout is not very widespread, it is probably not worth adding it to the software. Did I understand correctly that this issue is now resolved apart from the message in the log?

comment:5 Changed 5 years ago by rhertzog

Well, the layout is gaining momentum but it's clearly a very small minority in France that is using it right now.

For me this issue is resolved in 2.0.6 but I don't know why. How does he fallback to Azerty if he can only see my Bépo layout? Or does it analyze the alternate layouts too?

comment:6 Changed 5 years ago by michael

  • Status changed from new to closed
  • Resolution set to fixed

When keys on the keyboard are pressed, they send keycodes which do not depend on the current layout. The only problem for VirtualBox is to work out which X11 keycodes correspond to which keys (this is not set in stone). We have two methods for doing this, one of which involves looking at the keyboard layout, and which will fail if we don't know the layout. The guest system only sees PC scan codes, and has no idea about the host layout.

comment:7 Changed 5 years ago by jmason

Hi there -- I'm seeing this problem with VirtualBox 2.1.0 under Intrepid; in a RHEL 5.2 guest, all the keys are scrambled. according to xorg I'm using:

(II) XINPUT: Adding extended input device "Microsoft Natural? Ergonomic Keyboard 4000"

(type: KEYBOARD)

() Option "xkb_rules" "evdev" () Microsoft Natural? Ergonomic Keyboard 4000: xkb_rules: "evdev" () Option "xkb_model" "pc105" () Microsoft Natural? Ergonomic Keyboard 4000: xkb_model: "pc105" () Option "xkb_layout" "ie" () Microsoft Natural? Ergonomic Keyboard 4000: xkb_layout: "ie" () Option "xkb_options" "lv3:ralt_switch" () Microsoft Natural? Ergonomic Keyboard 4000: xkb_options: "lv3:ralt_switch" () Microsoft Natural? Ergonomic Keyboard 4000: YAxisMapping: buttons 4 and 5 () Microsoft Natural? Ergonomic Keyboard 4000: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200

Any suggestions? Since I already remap my keyboard to a US mapping using xmodmap after starting my session, I don't really need to use the "ie" XKB layout. if I change that, would it help?

comment:8 Changed 5 years ago by frank

Please could you attach a VBox.log file?

Changed 5 years ago by jmason

vbox.log from IE keyboard

comment:9 Changed 5 years ago by jmason

There's my vbox.log. thanks!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use