VirtualBox

Ticket #2340 (closed defect: duplicate)

Opened 6 years ago

Last modified 5 years ago

Uanble to build linux additions for debian Lenny amd64 guest

Reported by: KeyzerSuze Owned by:
Priority: major Component: shared folders
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Linux
Host type: other

Description

I have debian amd64 lenny guest which running on 2.0.2, where I have been unable to load the xboxvfs modules

when attempting to load the module I get these errors in dmesg

vboxvfs: disagrees about version of symbol RTSpinlockCreate vboxvfs: Unknown symbol RTSpinlockCreate

and it fails

Change History

comment:1 Changed 5 years ago by OxOOCOFFEE

Same problem here. Running VBox 2.0.4 Host(Vista 64) guest Xubuntu 8.10 64bit. ubuntu:/var/log$ sudo modprobe vboxvfs FATAL: Error inserting vboxvfs (/lib/modules/2.6.27-7-generic/misc/vboxvfs.ko):

dmsg: [ 1062.362995] vboxvfs: disagrees about version of symbol RTSpinlockCreate [ 1062.363033] vboxvfs: Unknown symbol RTSpinlockCreate

I try to rebuild it with the vbox tools from 2.0.4. There were no errors when building. Becouse of this mount -t vboxsf failes.

lsmod | grep vbox only returns vboxadd.

Looking in /lib/modules/2.6.27-7-generic/misc/ bot ko files (vboxadd.ko and vboxvfs.ko) exists and have the same time stamp when I reinstalled the tools

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #2550. See the solution posted there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use