VirtualBox

Ticket #233 (closed defect: duplicate)

Opened 7 years ago

Last modified 7 years ago

Write-through VDI disk - "Delayed Write Failed" errors in XP

Reported by: lechroom Owned by:
Priority: critical Component: other
Version: VirtualBox 1.3.8 Keywords:
Cc: Guest type: other
Host type: other

Description

Host: Ubuntu 6.06 Guest: Windows XP Home SP2 VDI file: 4GB fixed-size, set as write-through

Installing XP guest from scratch ends up in "Delayed Write Failed" errors during the install process.

If the VDI is created as "normal", the XP install goes fine as usual. But as soon the VDI is set to "write-through", the same errors start to occur every 2 or 3 minutes and make it impossible to install any other large software

Disabling the cache in XP (Explorer/right click on disk C: / Properties / Policies ) doesn't help.

Didn't try the set VBOX_DISABLE_HOST_DISK_CACHE=1 trick as this applies theorically to iSCSI targets.

Change History

comment:1 Changed 7 years ago by lechroom

same errors using Windows XP Pro SP2 as a host instead of Ubuntu

comment:2 Changed 7 years ago by klaus

Are you sure you don't have problems with the file system where the VDI is stored? We had an earlier report #195 with the same symptoms, and it turned out that the VDI was stored on a FAT32 partition. FAT32 has a 4G-1Byte limit on Windows (and 2G-1Byte on Linux), so you could hit that limit.

comment:3 Changed 7 years ago by lechroom

Yep, I should have read closed tickets more precisely...

The VDI was on a FAT32 partition. It probably began to grow (even if it was fixed-size...) until it reached the 4GB limit. Having the VDI set as "normal" always created a supplemental differencing file so it didn't happen then.

Changing the filesystem did solve the problems. Thanks for the support and the incredible work!

comment:4 Changed 7 years ago by klaus

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate of #195

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use