VirtualBox

Ticket #2320 (reopened defect)

Opened 6 years ago

Last modified 4 years ago

"Close Virtual Machine" dialog pop up at boot up.

Reported by: tienhn Owned by:
Priority: major Component: GUI
Version: VirtualBox 3.0.6 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

Recently, after upgraded to 2.0.2, I saw at random time (sometime frequently), the "Close Virtual Machine" dialog pop up during boot up. If I click Cancel then the boot process continued without and problem.

My two systems:
Host Ubuntu 8.0.4 AMD64, VirtualBox 2.0.2, Guess Windows XP
Host Ubuntu 8.0.4 x86, VirtualBox 2.0.2, Guess Windows XP

Here is the portion of the log where the VM got suspended:

00:01:25.471 Guest Additions information report: additionsVersion = 0x00010004  osType = 0x00033000
00:01:25.485 Guest reported fixed hypervisor window at 0x00000000f6000000 (size = 0xc00000, rc = VINF_SUCCESS)
00:01:25.496 Audio: set_record_source ars=0 als=0 (not implemented)
00:01:25.497 Audio: set_record_source ars=0 als=0 (not implemented)
00:01:25.510 OHCI: Software reset
00:01:25.510 OHCI: USB Reset
00:01:25.510 OHCI: USB Operational
00:01:25.602 SharedFolders host service: connected, u32ClientID = 1
00:01:25.832 PCNet#0: Init: ss32=1 GCRDRA=0x06975420[64] GCTDRA=0x06975020[64]
00:01:26.631 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00007f67ae000000 w=1920 h=1056 bpp=32 cbLine=0x1E00
00:01:26.632 VBVA: Enabled.
00:01:26.696 OHCI: USB Suspended
00:01:26.874 Guest requests mouse pointer integration
00:01:26.883 Changing the VM state from 'RUNNING' to 'SUSPENDED'.
00:01:32.816 Changing the VM state from 'SUSPENDED' to 'RUNNING'.
00:01:33.120 EHCI: USB Suspended
00:01:35.398 NAT: DHCP offered IP address 10.0.2.15
00:01:35.646 PCNet#0: Init: ss32=1 GCRDRA=0x06975420[64] GCTDRA=0x06975020[64]

Attachments

WinXP-1-2008-09-25-09-43-52.log Download (57.1 KB) - added by tienhn 6 years ago.
VM got suspended at boot up
coldboot-vm.log Download (34.3 KB) - added by prtsoftware 5 years ago.
prtsoftware's log file during cold-boot of an XP VM
reboot-vm.log Download (38.9 KB) - added by prtsoftware 5 years ago.
prtsoftware's log file during reboot of the XP VM (no close vm dialog)
no-guest-addtions.log Download (41.2 KB) - added by prtsoftware 5 years ago.
Log file of VM without guest additions (boots fine)
VBox_no_suspend.log Download (45.6 KB) - added by sernc11 5 years ago.
VBox_suspend.log Download (45.8 KB) - added by sernc11 5 years ago.
vbox2.1.2.log Download (34.8 KB) - added by wczimmerman 5 years ago.
Log file for 2.1.2 when the pause/hang/prompt occurs
VBox.log Download (34.2 KB) - added by catkin 5 years ago.
Log. 3.0.2 on ubuntu 8.04.2 with WXP SP2 guest
VBox.2.log Download (35.5 KB) - added by catkin 5 years ago.
Log after cancelling dialog. 3.0.2 on ubuntu 8.04.2 with WXP SP2 guest

Change History

Changed 6 years ago by tienhn

VM got suspended at boot up

comment:1 Changed 5 years ago by prtsoftware

I have the exact same problem with my virtual machine on Ubuntu 7.10 after upgrading to 2.02. Hitting Cancel lets me boot the VM. To me it looks like a mouse-pointer integration bug of some sorts, as I was also seeing "The Virtual Machine reports that the guest OS does not support mouse pointer integration in the current video mode" warning when rebooting the VM.

Attached is the cold-boot-VM-log and the restart-VM-log (Start/Turn Off/Restart).

Changed 5 years ago by prtsoftware

prtsoftware's log file during cold-boot of an XP VM

Changed 5 years ago by prtsoftware

prtsoftware's log file during reboot of the XP VM (no close vm dialog)

comment:2 Changed 5 years ago by prtsoftware

The boot problem went away after I uninstalled Guest Additions under XP. I can now cold-boot the VM without the Close Virtual Machine dialog appearing.

I never noticed before, but the guest additions that I uninstalled was version 1.62. I'm surprised at the version number because I believe I reinstalled Guest Additions on this VM after upgrading to 2.02.

When I installed Guest Additions from the VM menu, it did say that it was installing Guest Additions version 2.02. Note: The dialog box warning of the unsigned driver appeared under the main dialog, so for a bit I thought the Guest Additions was hung at the "installing video driver..." step.

During reboot the Close Virtual Machine Dialog appeared once again, indicating that this is probably a Guest Additions issue. Again, pressing Cancel let me by the dialog

After installing I confirmed that it was indeed Guest Addtions 2.02 that was installed. The VirtualBox Mouse icon shows that the VM starts up in Mouse Integration mode.

Uninstalling Guest Additions 2.02 allows the VM to start without the Close Virtual Machine Dialog appearing. I will attach the log to this incident as no-guest-addtions.log.

Changed 5 years ago by prtsoftware

Log file of VM without guest additions (boots fine)

comment:3 Changed 5 years ago by prtsoftware

Can someone please change the component to "guest additions" so that it can be fixed by someone working on that code?

Thanks,

Prtsoftware

comment:4 Changed 5 years ago by frank

  • Description modified (diff)

comment:5 Changed 5 years ago by prtsoftware

I can reliably reproduce this exact bug. It happens every time I boot my VM and Guest Additions 2.02 is installed.

Host Ubuntu 7.10 x86, VirtualBox 2.0.2, Guest Windows XP

Tienhn, can you verify this problem goes away on your machine if you uninstall Guest Additions?

Thanks, Prtsoftware

comment:6 Changed 5 years ago by tienhn

prtsoftware, Yes I can confirm that the problem went away without Guest Addition (that was the first thing I checked). As you can see in the log:

00:01:26.874 Guest requests mouse pointer integration 00:01:26.883 Changing the VM state from 'RUNNING' to 'SUSPENDED'. 00:01:32.816 Changing the VM state from 'SUSPENDED' to 'RUNNING'.

As soon as the Guest request mouse pointer is done, the dialog pop up.

Cheers,

comment:7 Changed 5 years ago by prtsoftware

This bug appears to be fixed in 2.04.

Prtsoftware

comment:8 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:9 Changed 5 years ago by tienhn

frank, Prtsoftware stated "appears to be fixed" and I know from my system that it does not happen consistently. Once it a while it would pop up. So far since my upgraded to 2.0.4 it has not popped up yet. However, unless you have access to a bug log where it stated that this problem was found and fixed, I would not close it yet. Do you agree?

Cheers,

comment:10 Changed 5 years ago by catkin

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hello :-)

The symptoms described by tienhn in the initial report have just started happening on a 2.0.4 system. The same .vdi file has been used with PUEL 1.6.2, 1.6.6, 2.0.4, and the current 2.0.6 without the symptoms happening until recently (first occurrence not logged) when they are happening each of at least the last 3 boots. 2.0.4 was removed and 2.0.6 was installed on 8dec8. The VM is started at least once a day.

Host: ubuntu 8.04.1 (Hardy) last updated and upgraded 8dec8 VirtualBox: PUEL 2.0.6 Guest: Windows XP Pro SP2 plus currrent hot fixes except KB957097 (slowed WXP access to SAMBA on host) Guest Additions: 2.0.6 (confirmed in Add or Remove Programs)

From the latest log: 00:01:45.777 Guest requests mouse pointer integration 00:01:45.777 Changing the VM state from 'RUNNING' to 'SUSPENDED'. 00:02:02.662 Changing the VM state from 'SUSPENDED' to 'RUNNING'.

All the previous 3 logs contain similar.

BTW all the logs also contain many repeats of lines like these (separate issue?): 00:02:04.357 Guest Log: VBOXNP: NPGetConnection: Returned error 0x43 00:02:04.364 Guest Log: VBOXNP: SendToMiniRdr: Returning error from DeviceIoctl! Status = 67

Best

Charles

comment:11 Changed 5 years ago by catkin

Sorry -- "just started happening on a 2.0.4 system" should read "just started happening on a 2.0.6 system"

comment:12 Changed 5 years ago by frank

  • Version changed from VirtualBox 2.0.2 to VirtualBox 2.0.6

comment:13 Changed 5 years ago by wczimmerman

I can confirm that this error is happening to me on Hardy with VBox 2.1.2 with 2.1.2 guest additions.

comment:14 Changed 5 years ago by michael

  • Version changed from VirtualBox 2.0.6 to VirtualBox 2.1.2

comment:15 Changed 5 years ago by frank

wczimmerman, please could you attach a VBox.log file for a 2.1.2 session when this problem happens?

comment:16 Changed 5 years ago by sernc11

My System: ubuntu 8.04 x64, guest: ubuntu 8.04 32 bit and Win XP I got the same problem starting from vbox 2.1.2-41885. Every time I re-start the X and at the first time I boot any of the guest OS, the dialog pops up.

However, if booting the same guest OS the second time, the dialog does not pop up.

Log file attached => VBox_no_suspend.log vs. VBox_suspend.log

Changed 5 years ago by sernc11

Changed 5 years ago by sernc11

Changed 5 years ago by wczimmerman

Log file for 2.1.2 when the pause/hang/prompt occurs

comment:17 Changed 5 years ago by wczimmerman

I uploaded my log as requested from when the problem occurs. Let me know if you need anything further.

comment:18 Changed 5 years ago by frank

wczimmerman, thanks for the log, still no idea. Any chance to test the latest release 2.2.2?

comment:19 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No response, closing.

comment:20 Changed 5 years ago by catkin

  • Status changed from closed to reopened
  • Resolution fixed deleted

Happening with VBox 3.0.2 on ubuntu 8.04.2 for both WXP SP2 and ubuntu 8.04.2 guests.

Had "gone away" prior to changing from 2.1.2-41885 to 3.0.2-49928 (by remove and install). Used to happen very early during guest boot; have now seen happening later. Happens > 50% of the boots.

Changed 5 years ago by catkin

Log. 3.0.2 on ubuntu 8.04.2 with WXP SP2 guest

Changed 5 years ago by catkin

Log after cancelling dialog. 3.0.2 on ubuntu 8.04.2 with WXP SP2 guest

comment:21 Changed 5 years ago by catkin

Still happening on 3.0.6 on ubuntu 8.04.3 with WXP SP2 guest. Is happening almost every guest boot now (easier to investigate?)

comment:22 Changed 5 years ago by sandervl73

  • Version changed from VirtualBox 2.1.2 to VirtualBox 3.0.6

comment:23 Changed 5 years ago by sandervl73

  • Component changed from VM control to GUI

comment:24 follow-up: ↓ 25 Changed 5 years ago by frank

Do you have any special Qt style installed?

comment:25 in reply to: ↑ 24 ; follow-up: ↓ 26 Changed 5 years ago by catkin

Replying to frank:

Do you have any special Qt style installed?

Not knowingly but I am using Xfce 4.6.1 from  https://launchpad.net/~jerome-guelfucci/+archive/ppa. I changed from a minimal installation of ubuntu hardy main packages (xfdesktop4 thunar mousepad xfce4-session xfce4-datetime-plugin -- as opposed to the full xubuntu-desktop) because of a problem discussed at  http://forums.virtualbox.org/viewtopic.php?f=7&t=12579&p=94870.

comment:26 in reply to: ↑ 25 Changed 4 years ago by catkin

Replying to catkin:

... I am using Xfce 4.6.1 from  https://launchpad.net/~jerome-guelfucci/+archive/ppa. I changed from a minimal installation of ubuntu hardy main packages (xfdesktop4 thunar mousepad xfce4-session xfce4-datetime-plugin -- as opposed to the full xubuntu-desktop) because of a problem discussed at  http://forums.virtualbox.org/viewtopic.php?f=7&t=12579&p=94870.

Update: problem went away with change of OS from ubuntu to Slackware.

A month ago I switched host OS from ubuntu 8.04.3 to Slackware 13.0 32-bit and have not seen the "Close Virtual Machine" dialog since. VirtualBox version same at 3.0.6 (but now from VirtualBox-3.0.6-52128-Linux_x86.run rather than repository "deb  http://download.virtualbox.org/virtualbox/debian hardy non-free"). Xfce version same at 4.6.1 (but now from the standard Slackware 13.0 installation CD .iso files). Sometimes now (~10%?) the WXP virtual machine disappears during startup but I figure that is a different problem.

comment:27 Changed 4 years ago by frank

Guess the problem is the Qt version of Ubuntu 8.04.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use