VirtualBox

Ticket #2309 (closed defect: fixed)

Opened 7 years ago

Last modified 6 months ago

Detect Hardware in XP crashes the VM (HD attached to AHCI port 0)

Reported by: TiCPU Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

I just added a serial port to the machine and wanted to install it in XP as it was not automatically detected, so I went in the device manager and clicked detect new hardware, the screen went black with some nice multicolor screen corruption.

Removing the serial port I just added also crashes the machine. Enabling VT also crashes the same way. In summary, clicking scan for hardware changes in XP just crashes VBox.

The host is Gentoo Linux, latest up-to-date version. The Virtual Machine is Windows XP Service Pack 3.

Attachments

crashed-vbox.png Download (32.5 KB) - added by TiCPU 7 years ago.
Crashed Virtual Box
XP-2008-12-11-13-38-55-stopped-automatically.log Download (62.0 KB) - added by TiCPU 6 years ago.
XP-2008-12-11-13-41-20-stopped-manually.log Download (62.4 KB) - added by TiCPU 6 years ago.
VBox.log Download (65.1 KB) - added by TiCPU 6 years ago.
VBox.Log for version 2.2.2 with matching add-ons and modules, after powering off manually.
xpvb-2009-12-01-17-00-49.log Download (45.7 KB) - added by bla0ck 5 years ago.
vb log
bsod.png Download (25.0 KB) - added by bla0ck 5 years ago.
crashed xp sp3 bsod
VBox.2.log Download (118.4 KB) - added by Squall Leonhart 6 months ago.
f6flpy-x64_11.2.0.1006.7z Download (476.0 KB) - added by Squall Leonhart 6 months ago.

Change History

Changed 7 years ago by TiCPU

Crashed Virtual Box

comment:1 Changed 7 years ago by frank

Please check again with VirtualBox 2.0.4. If the problem still happens, please attach a VBox.log file of such a crashed session. And please enable core dumps for your machine, see here for instructions. If you get a core dump, please send it to frank _dot_ mehnert _at_ sun _dot_ com (if not too big, use some upload service otherwise).

comment:2 Changed 6 years ago by TiCPU

With VBox 2.0.6 I get a Blue Screen instead: STOP: 0x000000F4 (0x00000003, 0xFFB68020, 0xFFB68194, 0x805FB046) See attached Virtual Box logs, one after the VM automatically shutdown, and the other when stopped on the Blue screen.

Changed 6 years ago by TiCPU

Changed 6 years ago by TiCPU

comment:3 Changed 6 years ago by kmix

FYI -- This was a problem for me also, but I was able to install the hardware after temporarily disabling the SATA controller.

comment:4 Changed 6 years ago by TiCPU

I confirm, disabling the SATA port allow me to scan for new hardware without a crash, even if the serial port I added wasn't detected ??

comment:5 Changed 6 years ago by aeichner

Which version of the Intel SATA drivers are you using?

comment:6 Changed 6 years ago by TiCPU

In the Device Manager, with SATA Enabled, I see:

Intel(R) ICH8M-E/M SATA AHCI Controller Date: 2008-06-07 Version: 8.2.0.1001

I've got virtualbox-modules-2.0.6 installed with latest VirtualBox guest tools too.

comment:7 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if this problem persists with the latest release 2.2.2.

comment:8 Changed 6 years ago by TiCPU

  • Status changed from closed to reopened
  • Resolution fixed deleted

Scan for new hardware works on IDE, it works with SATA AHCI enabled, switched my XP to SATA Port 0, and it crashed again! Nothing new.

Changed 6 years ago by TiCPU

VBox.Log for version 2.2.2 with matching add-ons and modules, after powering off manually.

comment:9 Changed 6 years ago by frank

  • Description modified (diff)

To be sure: You are talking about a crashing guest, not a crashing host, right?

comment:10 Changed 6 years ago by TiCPU

Yes exactly, the screenshot is the VirtualBox window but I can click on Machine -> Reset and it reboots. I will soon put a link to a whole machine and config soon with both the save state bug and this one.

comment:11 Changed 6 years ago by frank

I've removed your last comment to remove that URL from the public website. I'm currently downloading that stuff.

comment:12 Changed 6 years ago by frank

  • Summary changed from Clicking on detect hardware in XP crashes the VM to Detect Hardware in XP crashes the VM (HD attached to AHCI port 0)

comment:13 Changed 6 years ago by frank

  • Version changed from VirtualBox 2.0.2 to VirtualBox 2.2.2

comment:14 Changed 6 years ago by ToddAndMargo

I am having the same problem: Host: CentOS 5.3; guest XP-Pro-SP3. Scanning for hardware changes in the guest (XP) gives me the BSOD. VBox is 3.0.2.

Additional information: crashes with or without VB Guest Additions installed.

-T

Changed 5 years ago by bla0ck

vb log

Changed 5 years ago by bla0ck

crashed xp sp3 bsod

comment:15 Changed 5 years ago by bla0ck

Hi,

log and bsod of win xp guest on win xp host from my side attached.

This is a problem when using Cisco VPN any connect client as it also executes new hardware search during connection.

The workaround is to attach boot drive on IDE controller. Any other drive attached on AHCI controller seems to be lost by system during hardware scan.

Thanks for fixing this.

comment:16 Changed 5 years ago by bla0ck

BTW, I can reliably repro this on 3.1 55467 let me know in case you need more info.

Steps to reproduce:

  1. Install XP SP3 on IDE drive with AHCI controller enabled.
  2. Install latest Matrix storage driver from Intel. Mine is ICH8M-E/M AHCI Controller 8.9.0.1023.
  3. Shut down VM, re-attach HDD to AHCI controller port 0.
  4. Start VM and run Add hardware wizard.

Actual result - BSOD. Expected result - successful completion of wizard.

comment:17 Changed 4 years ago by wbic16

I'm able to reproduce this using Windows XP SP3 guest, AHCI SATA port 0, ICH8M-E/M, Ubuntu 64-bit 11.04 host, VirtualBox 4.0.6 r71344. Whenever I attempt to run the Add Hardware Wizard the VM just locks up.

comment:18 Changed 3 years ago by clarkjc

Hello,

I am able to reproduce this using a Windows XP x64 SP2 guest, AHCI SATA port 0, ICH8M-E/M, Ubuntu 11.10 64-bit host, and VirtualBox 4.1.10 r76795. Whenever "Scan for hardware changes" in selected in the Device Manager on the guest, the VM spontaneously reboots.

The problem does not occur when using the emulated PIIX4 IDE controller instead of the emulated ICH8M-E/M AHCI SATA controller.

Thank you.

Last edited 3 years ago by clarkjc (previous) (diff)

comment:19 Changed 3 years ago by frank

  • Description modified (diff)

Still reproducible with VBox 4.1.22?

comment:20 Changed 3 years ago by Squall Leonhart

yes, and 4.2

comment:21 Changed 2 years ago by Takeshi

Hello everyone ..

I am using VirtualBox 4.2.12 r84980, my guest is Windows XP SP3

When I do hardware scan, the VM Guest simply reboot .. After Digging for a while, I was able to find the Intel's 10.1.0.1088 version AHCI Driver

Intel(R)ICH8M-E/M SATA AHCI Controller 10.1.0.1088

It was bundled in RAID_F6_32bit_10.1.0.1008_PV self-extract Driver

and I am using ICH9 chip set, dual core CPU with Intel vt and 2GB ram .

help anyone?

comment:22 Changed 2 years ago by Squall Leonhart

use IDE for the emulated hdd's instead of ahci/sata

comment:23 Changed 2 years ago by Takeshi

so you can't use SATA for Windows XP for sure? there is no way to fix the broken function?

I mean ... XP already using ICH7, 10 with SATA device for a long time and VirtualBOX does have the function out there for SATA devices ..

but now we can't use SATA because it's broken? then what's the point of having SATA controller option?

comment:24 Changed 8 months ago by Kyo

Hi!

6 years later and with VM 4.3.12 I can confirm same behavior.

Byeee

comment:25 Changed 6 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Tried with VBox 4.3.20 and a Windows XP 64-bit guest. Everything works as expected. Add a virtual SATA controller and attached a virtual disk image to it. Windows reported new hardware. I've installed the Intel 10.1.0.1008 driver in the guest. The SATA controller was detected. Then tried to scan for new hardware, nothing new found but also no guest reboot.

If you consider to reopen this ticket, please try with VBox 4.3.20 and if you can still reproduce the problem, add the exact steps how to reproduce this problem with a WinXP guest or an WinXP64 guest.

comment:26 Changed 6 months ago by Squall Leonhart

NOT fixed.

The issue only manifests when the OS drive is on the sata controller, your 'test' as such would not replicate the crash because the system drive remains attached to the IDE host.

Changed 6 months ago by Squall Leonhart

comment:27 Changed 6 months ago by frank

Aha, interesting information. But is this problem reproducible with Vista or newer? Making this work for Windows XP is low-priority.

comment:28 Changed 6 months ago by frank

AFAICS the attached log does not show a crash and neither a guest reboot. But maybe you attached it to show your VM configuration.

Anyway, a crash of the VM process would be worth to investigate but if the guest just reboots then I doubt we will ever have time to debug this problem.

comment:29 Changed 6 months ago by Squall Leonhart

its a kernel inpage error bsod inside the guest, which i've narrowed down to the HDD being 'removed' when the 'check for new hardware' function is used.

I'm getting a new windows 7 iso from digitalriver to test, as i can't get to the install disk at the present time.

comment:30 Changed 6 months ago by Squall Leonhart

Reproducible on Windows 7 x64 with Intel RST drivers.

Microsoft AHCI driver not affected.

This test was on a custom RST 11 driver, as well as on the RST 10 driver you tested Frank.

comment:31 Changed 6 months ago by Squall Leonhart

and its certainly not the drivers, as i use them on my Host pc, something must not be right in the ich8 sata emulation that the intel driver enables :\

comment:32 Changed 6 months ago by frank

I would like to reproduce this problem with Windows 7. Actually it's not that easy to install custom drivers to Windows 7. I've downloaded the 13.2.4.1000 RST driver from Intel and try to update the Windows builtin driver with that one. Doesn't work, Windows says the current driver is already up-to-date. Pressing on "Scan for hardware changes" does not show any problem. Using Windows 7 / 32-bit with all recent updates.

comment:33 Changed 6 months ago by Squall Leonhart

13.2.4.1000 is not compatible with ICH devices, they dropped support for the ICH10 and lower after v11.7.4.1001 (no code support, except for RAID).

And actually, i think the specific chip that virtualbox emulates was removed in an even earlier version than that, they changed the way the device appears to the system with 11.5. (drives get (SCSI) in their names)

10.1.0.1008 natively supports the ich8-e/m and reproduces the problem, as does 11.2.0.1006, which i modified to include the device strings.

Changed 6 months ago by Squall Leonhart

comment:34 Changed 6 months ago by frank

Sorry, how to install this driver? From Device Manager / Standard AHCI1.0 Serial ATA Controller / Update Driver Software ... Windows still is not keen in replacing the driver.

comment:35 Changed 6 months ago by Squall Leonhart

Should be able to manually select it, you'll get a red warning that the driver is not signed but it should have a option to install it anyway.

comment:36 Changed 6 months ago by frank

I already wrote that I'm not able to manually change the driver. After updating the driver and selecting the directory with the driver files, Windows still thinks that the current driver is good enough and wouldn't install the manually selected driver.

comment:37 Changed 6 months ago by Squall Leonhart

  1. Browse my computer for driver software
  2. Let me pick from a list of device drivers on my computer" during the update wizard?
  3. Have Disk

if you run the dpinst.exe in the zip with the -lm command line it will install the driver via pnputil and will be present on the 'Let me pick....' screen.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use