VirtualBox

Ticket #2290 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

vbox 2.0.2 unable to create 64-bit guest on opensuse 11 x64 => Upgrade ASUS BIOS

Reported by: suchi Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

upgraded to vbox 2.02 on opensuse 11 x64 host. unable to create 64-bit guest vms, vbox sees my proc only as i586.

proc is virt-capable amd phenom 8450 3-core & bios has amd-v enabled.

here is a sample vbox guest settings list:

General Name Ubuntu-8.04.1-LTS-x64 OS Type Ubuntu Base Memory 1024 MB Video Memory 128 MB Boot Order CD/DVD-ROM, Hard Disk ACPI Enabled IO APIC Enabled VT-x/AMD-V Enabled PAE/NX Enabled

Hard Disks IDE Primary Master Enterprise Linux.vdi [Normal, 10.00 GB] CD/DVD-ROM Host Drive ASUS DRW-1814BL (/dev/sr0) Floppy Not mounted Audio Host Driver PulseAudio Controller ICH AC97

Network Adapter 1 Intel PRO/1000 MT Desktop (NAT) Adapter 2 Intel PRO/1000 MT Desktop (NAT)

Serial Ports Port 1 COM1, Disconnected USB Device Filters 0 (0 active) Shared Folders 2 Remote Display Disabled

have tried to install following guests on opensuse 11 x64 with vbox 2.0.2: linux 64: ubuntu hardy, rpath foresight, debian lenny, sles 10 unix 64: solaris 10, freebsd 7, nexenta b86 solaris installs 32-bit by default and rest say they need a 64-bit cpu but find only a i586 under vbox.

all above install individually without problems on physical partitions on same m/c, but then i will have a multiboot m/c rather then concurrent vms on one host... doesn't serve my purpose...

have also tried same vbox2.0.2 binary on ubuntu hardy x64, same prob there with vbox, so it seems to be a vbox bug thingie...

have even uninstalled vbox binary entirely and recompiled afresh from source, but problem persists...

cs

Attachments

VBox.log Download (51.8 KB) - added by suchi 6 years ago.
vbox log file for quoted session
VBox.2.log Download (51.8 KB) - added by suchi 6 years ago.
vbox log file for quoted session

Change History

comment:1 Changed 6 years ago by sandervl73

You could have saved yourself a lot of typing by just attaching the VBox.log file from the VM session. Please attach it anyway if you want me to say anything meaningful.

Changed 6 years ago by suchi

vbox log file for quoted session

Changed 6 years ago by suchi

vbox log file for quoted session

comment:2 Changed 6 years ago by frank

  • Summary changed from vbox 2.0.2 unable to create 64-bit guest on opensuse 11 x64 to vbox 2.0.2 unable to create 64-bit guest on opensuse 11 x64 => Check BIOS settings

suchi, according to your logs your VM had no AMD-V enabled. Please check your BIOS settings for any AMD-V-related settings. Without AMD-V (or VT-x on Intel boxes) it is not possible for VirtualBox to run 64-bit guests. After you enabled your BIOS settings, please verify that AMD-V is indeed enabled by looking at the session information dialog of that VM (HostKey+N).

comment:3 Changed 6 years ago by sandervl73

Frank is right. Either AMD-V is not enabled or your BIOS has incorrectly done so. If you have indeed enabled it, then you should try to find out if there's a new BIOS for your motherboard.

comment:4 Changed 6 years ago by suchi

hi frank, sandervl73 i noticed that. but if you will look once again at my original tt, i have mentioned that bios has amd-v enabled, and so it has, and correctly too. checked all that before creating a trouble ticket. and the bios i have for my mobo is also the most current one (v. 1401 20080917).

just in case, here are brief specs of the m/c: asus m3n-ht-delux-mempipe mobo, nforce8, phenom 8450 3-core 2.1 GHz, 8GB ECC unbuffered ddr2, dual-boot opensuse 11 x64 & win2k3 enterprise sp2 x64, both running vbox 2.02.

maybe it is worth seeing into if the phenom series of amd procs with barcelona cores and the pacifica extensions themselves have any virtualization limitations...

thanks for the help, and lets treat this ticket as closed, will post on the forums if i find a workaround or solve the issue. have a great day! suchi

comment:5 Changed 6 years ago by suchi

frank/sandervl73 the amd phenom 8450 proc (barcelona + pacifica) has "vme extensions" (8086 virtualization enhancements) that seem to support the creation and running of 386 vms.

below is proc/cpuid output for my proc:

processor : 0 vendor_id : AuthenticAMD cpu family : 16 model : 2 model name : AMD Phenom(tm) 8450 Triple-Core Processor stepping : 3 cpu MHz : 2109.545 cache size : 512 KB physical id : 0 siblings : 3 core id : 0 cpu cores : 3 fpu : yes fpu_exception : yes cpuid level : 5 wp : yes flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs bogomips : 4223.41 TLB size : 1024 4K pages clflush size : 64 cache_alignment : 64 address sizes : 48 bits physical, 48 bits virtual power management: ts ttp tm stc 100mhzsteps hwpstate

processor : 1 vendor_id : AuthenticAMD cpu family : 16 model : 2 model name : AMD Phenom(tm) 8450 Triple-Core Processor stepping : 3 cpu MHz : 2109.545 cache size : 512 KB physical id : 0 siblings : 3 core id : 1 cpu cores : 3 fpu : yes fpu_exception : yes cpuid level : 5 wp : yes flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs bogomips : 4218.65 TLB size : 1024 4K pages clflush size : 64 cache_alignment : 64 address sizes : 48 bits physical, 48 bits virtual power management: ts ttp tm stc 100mhzsteps hwpstate

processor : 2 vendor_id : AuthenticAMD cpu family : 16 model : 2 model name : AMD Phenom(tm) 8450 Triple-Core Processor stepping : 3 cpu MHz : 2109.545 cache size : 512 KB physical id : 0 siblings : 3 core id : 2 cpu cores : 3 fpu : yes fpu_exception : yes cpuid level : 5 wp : yes flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs bogomips : 4218.68 TLB size : 1024 4K pages clflush size : 64 cache_alignment : 64 address sizes : 48 bits physical, 48 bits virtual power management: ts ttp tm stc 100mhzsteps hwpstate

would be interested in finding our if there are others facing this problem. suchi

comment:6 Changed 6 years ago by sandervl73

VME has nothing to do with AMD-V. Yes, your CPU has AMD-V support. The fact is that it's incorrectly enabled by the BIOS. A disabled bit it set which according to the AMD manuals means that AMD-V (aka SVM) is disabled. This is not reversable at runtime.

comment:7 Changed 5 years ago by Deanjo

This issue has been verified, I have the same motherboard and the same issue is plaguing me. The issue is replicable in opensuse and windows xp64. VMware however works flawlessly. Sisoft sandra in windows also reports that SVM is enabled.

comment:8 Changed 5 years ago by Deanjo

I just ran the AMD Hyper-V ready test and it says that the BIOS is not ready for it. I'm filing a bug with Asus for this.

comment:9 Changed 5 years ago by Deanjo

After a month of fighting with Asus, this has finally been fixed in a upcoming BIOS release 1701. Just tested it tonight and it works.

comment:10 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from vbox 2.0.2 unable to create 64-bit guest on opensuse 11 x64 => Check BIOS settings to vbox 2.0.2 unable to create 64-bit guest on opensuse 11 x64 => Upgrade ASUS BIOS

Thanks for the feedback. Closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use