VirtualBox

Ticket #2257 (closed defect: invalid)

Opened 6 years ago

Last modified 6 years ago

Cannot overwrite files in shared folders

Reported by: anbrs1 Owned by:
Priority: major Component: shared folders
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Windows XP SP2 guest with Guest Additions 2.0.2r36486, Ubuntu 8.04 host.

If I try to copy a file to a shared folder and it already exists there, and I click "Yes" in the Confirm File Replace dialog, I get an error dialog titled "Error Copying File or Folder" that says "Cannot copy <filename here>: The parameter is incorrect." After that, the file to be overwritten is gone.

However, I am able to open, modify, and save files in the shared folder (usually) without errors.

In what may be a symptom of the same bug, if I use shell redirection to overwrite a file in a shared folder, the old file is not truncated properly. Assuming X: is the shared folder drive, at the command prompt:

x: echo asdf123456789 > trunc.txt more trunc.txt

--> asdf123456789

echo qwer > trunc.txt more trunc.txt

--> qwer

456789

The same thing happens when I overwrite a file using a Python script: if the new version is shorter, the tail of the old one remains.

Change History

comment:1 Changed 6 years ago by michael

I wasn't able to reproduce this. I was using the current development version of VirtualBox with the most recent guest additions installed. Is everything in your setup up to date? If so, can you try to find a recipe to reproduce this with a clean VM installation?

comment:2 Changed 6 years ago by anbrs1

Actually, I can't reproduce it either with a fresh install of Windows XP or after adding SP3. Looks like it may just be something gone wrong with my Windows installation.

By the way, there are some missing line breaks in the commands above..

comment:3 Changed 6 years ago by michael

  • Status changed from new to closed
  • Resolution set to invalid

I will close this ticket. Please feel free to reopen it if you see the issue again.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use