VirtualBox

Ticket #2252 (closed defect: duplicate)

Opened 10 years ago

Last modified 10 years ago

Changing debug registers via thread context doesn't work

Reported by: Tim Sobolev Owned by:
Priority: major Component: VMM
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Changing debug registers via thread context doesn't work on guest Windows XP, so no level-3 debuggers can't stop at hardware breakpoints.

Attachments

dbg.cpp Download (1.3 KB) - added by Tim Sobolev 10 years ago.
Source file to test issue (you have to compile without optimization)
dbg.exe Download (48.0 KB) - added by Tim Sobolev 10 years ago.
Compiled file to test issue

Change History

Changed 10 years ago by Tim Sobolev

Source file to test issue (you have to compile without optimization)

Changed 10 years ago by Tim Sobolev

Compiled file to test issue

comment:1 Changed 10 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #477.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use