VirtualBox

Ticket #2245 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Virtualbox 1.6.x - 2.0 black screen when starting any VM

Reported by: netoor Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

When starting any (Ubuntu, FreeDos, Windows) virtual machine (either bootable iso image or vdi file) in VirtualBox on Ubuntu 8.04.1 there is only black screen displayed and the VM doesn't start at all. In 1.6.x vesrions a gray background of the bootable image could be seen when it's stopped, in 2.x it's all black. VirtualBox is installed from deb package successfully but isn't working.

PC configuration:

  • Intel based motherboard i945G, 1GB, Celeron 2530MHz, S-ATA 80GB, integrated graphics. OS: Ubuntu 8.04.1 (russian)

Threads on the forum, that I've tried with no success (for example IO APIC support,e etc):

Attachments

fedora9-2008-09-15-11-04-25.log Download (41.5 KB) - added by netoor 6 years ago.
fedora9-2008-09-15-11-04-25.2.log Download (41.5 KB) - added by netoor 6 years ago.
freedos-2008-09-15-11-00-43.log Download (40.3 KB) - added by netoor 6 years ago.
winxp-2008-09-15-11-05-59.log Download (45.1 KB) - added by netoor 6 years ago.

Change History

Changed 6 years ago by netoor

Changed 6 years ago by netoor

Changed 6 years ago by netoor

Changed 6 years ago by netoor

comment:1 Changed 6 years ago by frank

Sounds like a problem with your graphics drivers. What happens if you

  • boot the VM with VBoxSDL -startvm fedora9?
  • boot the VM with VirtualBox -startvm fedora9 -rmode image?

comment:2 Changed 6 years ago by netoor

to frank: it didn't help. the problem continues..

comment:3 follow-up: ↓ 4 Changed 6 years ago by frank

  • Description modified (diff)

Ok. To rule out the host graphics driver: Could you change your host Xorg setup to use the VESA graphics driver? Edit the file /etc/X11/xorg.conf and add a section

  Section "Device"
        Identifier      "vesa"
        Driver          "vesa"
  EndSection

and add the line

  Device "vesa"

to the Screen section of that file. Then restart the X server to ensure the new configuration applies. Check in /var/log/Xorg.log.0 if the vesa driver is indeed used. Note that the graphics performance will be notably slower. Now try to start a VM. Still only a black window?

comment:4 in reply to: ↑ 3 Changed 6 years ago by netoor

Replying to frank:

Ok. To rule out the host graphics driver: Could you change your host Xorg setup to use the VESA graphics driver? Edit the file /etc/X11/xorg.conf and add a section

  Section "Device"
        Identifier      "vesa"
        Driver          "vesa"
  EndSection

and add the line

  Device "vesa"

to the Screen section of that file. Then restart the X server to ensure the new configuration applies. Check in /var/log/Xorg.log.0 if the vesa driver is indeed used. Note that the graphics performance will be notably slower. Now try to start a VM. Still only a black window?

yes, vesa drivers started successfully, but the result is the same. the system works fine with default xf86-video-intel (2:2.2.1-1ubuntu13.6) driver, but the screen is still black. VMWare works good

comment:5 Changed 6 years ago by frank

I already assumed that your system works fine with the default graphics driver so that was the reason why I asked you for testing VirtualBox with the VESA driver. So as VirtualBox shows you a black screen if started on a VESA X display, we can rule out the graphics driver. Please correct me if I understood you wrong.

I'm sorry but I have to ask you to be 100% sure: Did you really test

VirtualBox -startvm VM_NAME -rmode image

with VirtualBox 2.0.2? Note that this switch was not available prior to VirtualBox 2.0.2. To verify that the image mode is indeed used please start some VM without guest additions and shrink the window using the mouse. You should now see scrollbars and you should be able to drag them and to move them. Please forgive me but I have to be 100% sure that the image mode does not solve the problem for you.

comment:6 Changed 6 years ago by netoor

yes, at last! I tried doing as you've recommended, but I thought I had to do like this: VirtualBox -startvm freedos.iso -rmode image. After having registered my VMs in VirtualBox and starting like in your last post, it worked. Thank you very much for support! Now it's perfect. But one more question: should I always do like this from command line or I can change some preferences in VBox to make -rmode image permanent? Again, thank you!

comment:7 follow-up: ↓ 8 Changed 6 years ago by frank

Ok, the problem is the SDL library on your system which is somehow not working properly. Unfortunately you have to start your VMs using this command line as this parameter cannot be passed from the GUI. But you could try to fix the SDL stuff to get the VMs working without that switch.

Could you check if the following command works:

VBoxSDL -startvm freedos.iso

? I assume that this command does not work for some reason. Do you see any error message?

comment:8 in reply to: ↑ 7 Changed 6 years ago by netoor

Could you check if the following command works:

VBoxSDL -startvm freedos.iso

? I assume that this command does not work for some reason. Do you see any error message?

rom@ROMPC:/media/diskd/lin$ VBoxSDL -startvm fdbasecd Sun xVM VirtualBox SDL GUI 2.0.2 built Sep 12 2008 13:58:58 Error: machine with the given ID not found!

ok, looking forward sdl for solving my problems. probably those forum topics are about that too, I'll post there a message, let them try. thanks!

comment:9 Changed 6 years ago by frank

Please make sure that you specify a VM with a valid VM, i.e. one which you could start with VirtualBox -startvm ... as well.

comment:10 Changed 6 years ago by netoor

ok, made a mistake again. Now, the right output: rom@ROMPC:~$ VBoxSDL -startvm fedora Sun xVM VirtualBox SDL GUI 2.0.2 built Sep 12 2008 13:58:58 SDL Error: 'Unable to open a console terminal'

and exits...

rom@ROMPC:~$ sdl-config --version 1.2.13

In Synaptic I can see that 1.2.13 version of SDL is installed

comment:11 Changed 6 years ago by netoor

After writing last comment, I've downloaded the sources of SDL-1.2.13 from  http://www.libsdl.org/, compilled it and installed. Now everything works fine in a simple way (VirtualBox -startvm fedora). My problem is solved. My sincere gratitude, frank

comment:12 Changed 6 years ago by frank

Hmm. Wouldn't it be easier to install the SDL package? But at the other hand, the virtualbox-2.0 package depends on libsdl1.2debian (I still assume you are using Ubuntu/Hardy). Can you tell me if that package is actually installed and if yes, which version?

comment:13 Changed 6 years ago by netoor

There was libsdl1.2debian (1.2.13-1ubuntu1 (hardy)) and all it's dependencies installed by default in my system. But there were those problems as we could see. By the way, Dosemu also complained about sdl, now it works too. Something weird

comment:14 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Since VirtualBox 2.1.0, -rmode image is default. Closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use