VirtualBox

Ticket #2213 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

FreeBSD completely broken with hardware virtualization enabled

Reported by: fzzzt Owned by:
Priority: major Component: VMM/HWACCM
Version: VirtualBox 2.0.2 Keywords: freebsd 7 vt-x amd-v hardware 2.0.2
Cc: Guest type: BSD
Host type: Windows

Description

I had FreeBSD 7 somewhat working in 1.6.4, but after moving to 2.0 (and then 2.0.2) it seems to be completely broken. Like, badly--BUT--only when hardware virtualization is enabled. With HV turned off, it seems to run okay (I installed and booted from disk just fine with HV off). Unfortunately I can't run two VMs this way. :(

When you boot (after installing with HV off) or try to install, the same thing happens. The screen constantly gets flooded with "BTX halted" messages (too fast for me to read them). I will attach a screenshot and the log file; hopefully one or both will be visible and useful.

Attachments

FreeBSD 7.1-BETA on VirtualBox 2.0.2.jpg Download (75.4 KB) - added by fzzzt 6 years ago.
Screen shot of error message
VBox.log Download (40.7 KB) - added by fzzzt 6 years ago.
VirtualBox log file

Change History

Changed 6 years ago by fzzzt

Screen shot of error message

Changed 6 years ago by fzzzt

VirtualBox log file

comment:1 Changed 6 years ago by fzzzt

Oh, a couple things I didn't mention:

  1. On the bright side though, with HV off and the VM running I finally have low CPU usage (which never happened in 1.6). :)
  1. I tried every combination of I/O APIC, ACPI and HV (FreeBSD is sometimes really picky about ACPI) but nothing helped, other than turning HV off.
  1. FreeBSD 7.0 gave me the same results.

comment:2 Changed 6 years ago by frank

  • Component changed from host support to VMM/HWACCM

comment:3 Changed 6 years ago by martin

I can confirm the exact same problem. I have Guest FreeBsd 7.0 / Host Vista Sp1 The system is Intel Core2Duo

It was last runnig fine (with VT-x) on VBox 1.6.6 It fails on both 2.0.0. and 2.0.2 (same BTX halted)

comment:4 Changed 6 years ago by creepynut

I can confirm the same problem on Ubuntu Hardy host. VirtualBox 2.0.2.

comment:5 Changed 5 years ago by giovanni.toraldo

I can confirm the same problem on Debian Lenny host, Virtualbox 2.0.4.

comment:6 Changed 5 years ago by dickeywang

The same problem occurs in Virtualbox 2.0.6 (Host: Ubuntu 8.04.01 64-bit)

comment:7 Changed 5 years ago by martin

Is there any idea / inside knowledge which priority this bug has? or when a solution can be expected? I am aware this can not exactly be predicted, but at least things like "its top prior" or "there are 20 other bugs that go first" could be used to indicate a lead time?

comment:8 Changed 5 years ago by martin

Well, done (except for the fact that if you do not wish to give feedback: say so. Do not just ignore people who ask, please).

Anyway, I am going to provide feedback:

I have tested this Issue under VBox 2.1 with FreeBSd 6.2 and 7.0. Both went past he bootloader with no problem at all. (With VT-x enabled and with VT-x disabled).

So it does seem you fixed this bug.

FreeBsd 6.2 (that's the one your documentation says to have problems) booted all the way through and I can login and run applications. (I haven't checked for the SigReturn issue...)

FreeBSd 7.0 loads the kernal and dies at a later boot stage (separate bug report will be filled on this)

Thanks a lot.

comment:9 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback. The problem described here is solved then.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use