VirtualBox

Opened 6 weeks ago

Closed 3 weeks ago

#22045 closed defect (fixed)

VirtualBox 7.0.16 crashing host OS immediately with a BSOD by VBoxNetLwf.sys

Reported by: kabu Owned by:
Component: host support Version: VirtualBox-7.0.16
Keywords: Cc:
Guest type: all Host type: Windows

Description

After upgrade to Virtualbox 7.0.16 many users are reporting crash of Windows 11 host machine with BSOD in VBoxNetLwf.sys Bug Chekc String: PAGE_FAULT_IN_NONPAGED_AREA Bug Check Code: 0x00000050

Downgrading to 7.0.14 resolves problem.

For me it crash after Oracle Linux 8 is booted and I do "cat /proc/meminfo" or "top" under 5.15.0-202.135.2.el8uek kernel, but fails also under 5.4.7 uek kernel. Other users reported crash just after startup Ubuntu 20.04 guest or Windows 10 guest.

Here are forum posts with more and more users reporting problem after 7.0.16 upgrade https://forums.virtualbox.org/viewtopic.php?t=111417 https://forums.virtualbox.org/viewtopic.php?t=111418 https://forums.virtualbox.org/viewtopic.php?t=111370

One user noticed that after disabling wifi network in guest crash does not occour. Once enabled, it crashes in VBoxNetLwf.sys.

Change History (17)

comment:1 by kabu, 6 weeks ago

Forum https://forums.virtualbox.org/viewtopic.php?t=111417 was updated with report also on Windows 10 host and attached windbg.txt report: "BSOD's in 7.0.16 on Windows 10 host immediately when connecting via RDP to a Fedora 39 guest"

comment:2 by jfmorin, 6 weeks ago

I reproduced the same issue with a Windows 10 host and a Windows 10 guest. Both are up to date (22H2 with the latest updates). Lucky I had a fresh backup of the VM that got corrupted in the process!

comment:3 by Simple, 6 weeks ago

Windows 10 Host crashes when a Bridged Adapter is attached to my Intel WiFi 6E AX210 Adapter. The problem disappears when the Bridged Adapter is changed to any other type, like NAT or Host-only etc. This problem does not happen when running Win XP, Win 7 or Linux guests. P.S. I have the latest Intel drivers installed.

comment:4 by ronaldmacdonald, 6 weeks ago

The same issue with a Windows 10 VDI container under W11 23H2 - one machine with BSOD the other one lead to a freezed W11 system. Both systems runnung W11 23H2 - HW: AMD Ryzen 7 5700x 8c - Downgrade to 7.0.14 solves the problem.

Recommendation: stop rolling out 7.0.16 immediately and investigate the critical issue!

Ronald, IT Professional and 3rd lvl support engineer, Univ.-Goettingen, Germany

Last edited 6 weeks ago by ronaldmacdonald (previous) (diff)

comment:5 by haltcatchfire, 6 weeks ago

Similar symptoms, different details.

On Windows 11 21H2 build 22000.2899, stop code PAGE_FAULT_IN_NONPAGED_AREA , driver VBoxNetAdp6.sys.

Host uses WiFi.

I use NAT networking, host-only networking and two different internal networks among three guests. No bridge adapters.

All the guests are Linux (Debian stable, Fedora 39). All the guest ethernet adapters are of type Intel PRO/1000 MT Desktop.

Last edited 6 weeks ago by haltcatchfire (previous) (diff)

comment:6 by billyy62, 6 weeks ago

been having this too on RockyLinux getting the PAGE_FAULT_IN_NONPAGED_AREA

VBoxNetAdp6.sys

comment:7 by kabu, 6 weeks ago

I can confirm, that if the Host Only networking is used instead of bridged one, then Windows crash is in VBoxNetAdp6.sys instead of VBoxNetLwf.sys

There are currently over 10 Virtualbox users on forum reporting Windows 10/11 host crash in VBoxNetLwf.sys or VBoxNetAdp6.sys after upgrade to 7.0.16 version. Just one day after 7.0.16 release. Downgrade to 7.0.14 fixes it.

This looks like 7.0.16 regression.

Last edited 6 weeks ago by kabu (previous) (diff)

comment:8 by satalink, 6 weeks ago

I experienced the same (BSOD). Had to rollback to 7.0.14.

comment:9 by dallasjw, 6 weeks ago

Same issue here: Win 11 Host BSoD while running DietPi VM. Code: 0x00000050 I am remotely connecting to the host via RDP. Intel Pro/1000 MT Desktop adapter set to bridge mode. Issue occurs as soon as I attempt to login to the remote interface for Transmission client in a host browser window.

comment:10 by koderr, 6 weeks ago

It crashes in this loop:

// VBoxNetLwf-win.cpp
for (int i = 0; i < pSG->cSegsUsed; i++)
{
    NdisMoveMemory(pDst, pSG->aSegs[i].pv, pSG->aSegs[i].cb);   // <--
    pDst += pSG->aSegs[i].cb;
}

The only change since the last version in VBoxNetFlt for Windows was:

// VBoxNetFltRt-win.cpp
Status = vboxNetFltWinMemAlloc((PVOID*)&pSG, cbPacket + RT_UOFFSETOF_DYN(INTNETSG, aSegs[1]));

comment:11 by woody_, 6 weeks ago

Upgraded to 7.0.16, started a headless Fedora 39 server VM. As soon as I kicked off a DNF update check, the host blue screens and generates a memory dump. Went back to the latest test build I was running prior to the upgrade and no blue screens.

comment:12 by greyhame, 5 weeks ago

I also started seeing this issue. Any updates?

comment:13 by chue, 4 weeks ago

Hello,

I confirm the bluescreen caused by the vBoxNetAdp6.sys 7.0.16.162802 when launching an SSH from a host (with Cygwin or WSL2) to a VM containing a "Virtualbox Host-only Ethernet Adapter" interface.

The issue was first detected when running a playbook from WSL to a test VM (https://youtu.be/z6NPF9Q5FTA). I was able to isolate and simplify an SSH command that triggers the bluescreen (https://youtu.be/WMNd0ENDkKk):

bash

ssh -vvv -C -o 'User="ansible"' 192.168.56.101 '/bin/sh -c '"'"'echo ~ansible && sleep 0'"'"

The SSH logs indicate that the bluescreen occurs during or just after the TLS 1.3 handshake with the cipher chacha20-poly1305 (on Cygwin). The same command works fine using Windows SSH.

While waiting for a solution, I will downgrade the VirtualBox version.

Best regards,

comment:14 by mediastream, 4 weeks ago

same problem Win11 host. Ubuntu 22 server VM with Bridged Adapter. Every SSH attempt ends with BSOD "driver error on \Device\VBoxNetLwf"

Please advise

comment:15 by tonypi, 4 weeks ago

I too am running Ubuntu 22, hosted on Windows 11 and mine causes a crash as soon as I try to scp. I have reverted to 7.14 and it's ok now.

comment:16 by ronaldmacdonald, 3 weeks ago

FYI: maintenance release Virtualbox 7.0.18 has been released. Should be solved the VM crash error. Pls read the history / changelog of 7.0.18 for more information: https://www.virtualbox.org/wiki/Changelog-7.0

comment:17 by galitsyn, 3 weeks ago

Resolution: fixed
Status: newclosed

Hi guys,

We just released VirtualBox 7.0.18. This issue should be fixed in this release. It can be downloaded from here. Thank you for reporting the issue.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use