VirtualBox

Opened 6 months ago

Closed 4 months ago

#21911 closed defect (fixed)

RHEL 8.9 hangs after kernel update 4.18.0-513.5.1 => fixed in svn

Reported by: ISS Owned by:
Component: other Version: VirtualBox-7.0.12
Keywords: rhel kernel update hangs network adapter Cc: ISS
Guest type: Linux Host type: Windows

Description

Running RHEL update (dnf update) the kernel 4.18.0-513.5.1.el8_9.x86_64 (attachment # 1) was installed. Booting the system with the new kernel worked only the first time (attachment # 2), when it ran Firmware update daemon (attachment # 3).

After that, every time I try to boot the system using the new kernel, the VM just hangs after a warning about Unmaintained hardware (network adapter attachment # 4).

The attachment # 5 has the network card that has been working before this kernel (kernel 4.18.0-477.27.1.el8_8.x86_64 and prior).

The system works fine Booting with former kernels: 4.18.0-477.27.1.el8_8.x86_64 and 4.18.0-477.21.1.el8_8.x86_64

Any advice will be appreciated.

Attachments (11)

1 New kernel with issues.png (23.0 KB ) - added by ISS 6 months ago.
Kernel version that creates the issue
2. Kernel Booting options.png (21.2 KB ) - added by ISS 6 months ago.
Booting options
3. Booting new kernel and running Firmware update daemon.png (48.9 KB ) - added by ISS 6 months ago.
Running Firmware update after first boot with the new kernel
4. Hangs after booting new kernel 4.18.0-513.5.1.png (16.5 KB ) - added by ISS 6 months ago.
System hanges booting with the new kernel
5. Network adapter.png (30.3 KB ) - added by ISS 6 months ago.
Network adapter used by the VM
RHEL 8.5-2023-11-15-21-17-35 Kernel 4.18.0-513.5.1 Hangs.log (81.2 KB ) - added by ISS 6 months ago.
VBox log
Kernel.txt (35.1 KB ) - added by TziG 6 months ago.
RHEL 8.5-2023-12-01-14-14-34 kernel-4.18.0-513.5.1.el8_9.x86_64 .log (185.8 KB ) - added by ISS 6 months ago.
Log for kernel-4.18.0-513.5.1.el8_9.x86_64
RHEL 8.5-2023-12-01-14-14-34 kernel-4.18.0-513.5.1.el8_9.x86_64 Hardening.log (456.8 KB ) - added by ISS 6 months ago.
Hardening log for kernel-4.18.0-513.5.1.el8_9.x86_64
RHEL 8.5-2023-12-01-14-26-53 kernel-4.18.0-513.9.1.el8_9.x86_64.log (214.4 KB ) - added by ISS 6 months ago.
Log for kernel-4.18.0-513.9.1.el8_9.x86_64
RHEL 8.5-2023-12-01-14-26-54 kernel-4.18.0-513.9.1.el8_9.x86_64 Hardening.log (470.9 KB ) - added by ISS 6 months ago.
Hardening log for kernel-4.18.0-513.9.1.el8_9.x86_64

Download all attachments as: .zip

Change History (26)

by ISS, 6 months ago

Kernel version that creates the issue

by ISS, 6 months ago

Booting options

by ISS, 6 months ago

Running Firmware update after first boot with the new kernel

by ISS, 6 months ago

System hanges booting with the new kernel

by ISS, 6 months ago

Attachment: 5. Network adapter.png added

Network adapter used by the VM

comment:1 by galitsyn, 6 months ago

Hi ISS,

I did not spot the issue from log. Does it really hang forever or just building Additions kernel modules as shown on https://www.virtualbox.org/attachment/ticket/21911/3.%20Booting%20new%20kernel%20and%20running%20Firmware%20update%20daemon.png ?

How long did you wait?

comment:2 by TziG, 6 months ago

I am also having the same issue.

It hangs forever. I have waited over 20 minutes with no results. The older kernels indeed work as expected.

comment:3 by galitsyn, 6 months ago

Looking a bit closer to the log, I see there is a message "Snail execution mode is active!". This looks a bit suspicious. Could you please attach VBox.log when guest is running older kernel when issue does not occur?

I also suggest to try to get kernel log using this method https://www.virtualbox.org/wiki/Serial_redirect.

by TziG, 6 months ago

Attachment: Kernel.txt added

comment:4 by galitsyn, 6 months ago

Thank you for the log. This is kernel panic caused by vboxvideo kernel module. Problem is on our side and I’ll look at it. A quick workaround would be to temporary switch to VMSVGA graphics adapter in VM config.

comment:5 by galitsyn, 6 months ago

Summary: RHEL 8.9 hangs after kernel update 4.18.0-513.5.1RHEL 8.9 hangs after kernel update 4.18.0-513.5.1 => fixed in svn

Hi guys,

This issue should now be fixed on development branch. Could you please give a try to one of Guest Additions's test build?

comment:6 by TziG, 6 months ago

Issue is fixed. Sorry for modifying my answer all the time. I was downloading the VirtualBox rather than the newest guest additions.

Many many thanks!

Last edited 6 months ago by TziG (previous) (diff)

comment:7 by galitsyn, 6 months ago

No problem. Thank you for confirmation.

comment:8 by ISS, 6 months ago

Sorry for the late answer, but I did not get emails from your comments.

The workaround switching to VMSVGA graphics adapter in VM config works.

Just installing a newer version from test of the guest additions did not. I'm going to install the whole VBox test version and see if that solves the issue.

Last edited 6 months ago by ISS (previous) (diff)

by ISS, 6 months ago

Log for kernel-4.18.0-513.5.1.el8_9.x86_64

by ISS, 6 months ago

Hardening log for kernel-4.18.0-513.5.1.el8_9.x86_64

by ISS, 6 months ago

Log for kernel-4.18.0-513.9.1.el8_9.x86_64

by ISS, 6 months ago

Hardening log for kernel-4.18.0-513.9.1.el8_9.x86_64

comment:9 by ISS, 6 months ago

Hello again,

I installed VBox downloaded from Test, Version 7.0.13 r160458 (Qt5.15.2) with guest additions Extension_Pack-7.0.13-160260 and it still hangs.

I also updated the kernel to RH last version kernel-4.18.0-513.9.1.el8_9.x86_64 and it happened exactly the same: it hangs at boot time.

I've attached the logs for each kernel using this VBox version, hopping this may help to solve the problem.

Regards.

Last edited 6 months ago by ISS (previous) (diff)

comment:10 by ISS, 6 months ago

Status: newawaitsfeedback

comment:11 by ISS, 6 months ago

Hi

I also tried the development Version 7.0.97 r160499 (Qt6.3.0) with guest additions Extension_Pack-7.0.97-160499 and unfortunately the VM hanged as well with both kernels.

The only solution so far, is the workaround changing to VMSVGA the graphics adapter.

Greetings.

comment:12 by fth0, 6 months ago

@ISS: You're confusing the Guest Additions with the Extension Pack. Please try the separate Guest Additions 7.0.13r160546 or 7.0.97r160540 (or newer).

PS: The Extension Pack is installed on the host, the Guest Additions are installed in the guest.

in reply to:  12 comment:13 by ISS, 6 months ago

Replying to fth0:

@ISS: You're confusing the Guest Additions with the Extension Pack. Please try the separate Guest Additions 7.0.13r160546 or 7.0.97r160540 (or newer).

PS: The Extension Pack is installed on the host, the Guest Additions are installed in the guest.

Thanks for your comment @fth0.

I installed Guest Additions 7.0.13r160546 and it worked.

I'll consider the issue as closed.

Regards,

Last edited 6 months ago by ISS (previous) (diff)

comment:14 by almalinux_cloud_sig, 5 months ago

comment:15 by galitsyn, 4 months ago

Resolution: fixed
Status: awaitsfeedbackclosed

Hello,

We just released VirtualBox 6.1.50 and 7.0.14. This issue should be fixed there. You can download this version from here. Closing.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use