VirtualBox

Opened 8 months ago

Closed 4 months ago

#21875 closed defect (fixed)

Upgrading Guest Additions 7.0.10 -> 7.0.12 on Windows 8.1 makes it unbootable => fixed in 6.1.50 and 7.0.14 GAs

Reported by: karabaja4 Owned by:
Component: other Version: VirtualBox-7.0.12
Keywords: Cc:
Guest type: other Host type: other

Description

I upgraded to VirtualBox 7.0.10 -> 7.0.12.

I then booted Windows 8.1. guest, which booted fine with 7.0.10 Guest Additions.

Then I went and inserted Guest Additions CD image inside the guest and installed the new version of Guest Additions (7.0.12). Installation was successful, and then after installation rebooted my guest.

On the guest boot I was greeted with "Diagnosing your PC" and "Attempting repair" messages. After automatic repair failed, I was given the some options by Windows on what I can do.

I picked System Restore, and after Guest Additions were reverted back to 7.0.10 the OS was able to boot again.

I did this 3 times to confirm the issue.

C:\Windows\System32\LogFiles\Srt\SrtTrail.txt gives this message:

Root cause found:


Boot critical file d:\windows\system32\drivers\vboxguest.sys is corrupt.

Repair action: File repair Result: Failed. Error code = 0x2 Time taken = 3438 ms

*

Host: Arch Linux, kernel 6.1.58 Guest: Windows 8.1 x64

Attachments (1)

s23ayers-VirtualBoxLogs.7z (75.8 KB ) - added by s23ayers 8 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 by aheinlein, 8 months ago

I can confirm this is happening on a Windows 7 guest as well.

comment:2 by s23ayers, 8 months ago

I just encountered the same issue today. Host: Windows 11 Pro 10.0.22621 x64 Guest: Windows 8.1 x64

I am attaching my logs.

by s23ayers, 8 months ago

Attachment: s23ayers-VirtualBoxLogs.7z added

comment:3 by dolsys, 8 months ago

I have the same problem with Windows Server 2012!

comment:4 by badr-aldeen, 8 months ago

I also have windows 8.1 x64 which give black screen with VirtualBox logo on boot (because I used EFI shell) I do not have Restore point I could not boot into safe mode I will try to find a way to uninstall Gust addition 7.0.12 from WinPE

when I try to upgrade from 7.0.10 to 7.0.12 screen become glitch and I forced to restart then I found GA 7.0.12 installed but to make sure I do not have problem with 3D Graphic I reinstalled it again and that when I could not boot to windows

Last edited 8 months ago by badr-aldeen (previous) (diff)

comment:5 by isgdre, 8 months ago

I have same problem with Win10Pro host and Win7Untimate Guest.

comment:6 by orodriguez003, 8 months ago

I have the same problem, the virtual machine becomes corrupted

comment:7 by Klaus Espenlaub, 8 months ago

This is due to a code signing issue in guest additions (both 7.0.12 and 6.1.48 are affected) which manifests with Windows 8.1 and older. Use the files from the test builds page instead.

comment:8 by paulson, 4 months ago

Resolution: fixed
Status: newclosed
Summary: Upgrading Guest Additions 7.0.10 -> 7.0.12 on Windows 8.1 makes it unbootableUpgrading Guest Additions 7.0.10 -> 7.0.12 on Windows 8.1 makes it unbootable => fixed in 6.1.50 and 7.0.14 GAs

This has been resolved in the VirtualBox 7.0.14 GAs and the 6.1.50 GAs.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use