VirtualBox

Ticket #2182 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Raw vmdk does not work with SATA -> fixed in 2.0.4

Reported by: vkov_tinsky Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 2.0.0 Keywords: sata raw disk
Cc: Guest type: other
Host type: other

Description

Trying to start a VM with a raw vmdk attached in SATA mode results in the following error:

Unknown error creating VM.
VBox status code: -2 (VERR_INVALID_PARAMETER).

Result Code: 
NS_ERROR_FAILURE (0x80004005)
Component: 
Console
Interface: 
IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}
  • Attaching the raw vmdk using IDE works fine
  • Reproduced on hosts: Windows, Linux (Ubuntu 8.04, i686, kernel 2.6.24-21)
  • Problem not present on VirtualBox v1.6.6 (using same vmdk)

Attachments

VBox.log Download (26.2 KB) - added by vkov_tinsky 6 years ago.
Log for raw vmdk + SATA problem
Vbox-2008-09-13-20-03-15.log Download (31.3 KB) - added by misterjaytee 6 years ago.
Log for SATA problem on VirtualBox 2.0.0 and 2.0.2

Change History

Changed 6 years ago by vkov_tinsky

Log for raw vmdk + SATA problem

Changed 6 years ago by misterjaytee

Log for SATA problem on VirtualBox 2.0.0 and 2.0.2

comment:1 Changed 6 years ago by misterjaytee

I have the same problem on VirtualBox 2.0.2 (happened to me on 2.0.0 as well). Running Vista x64 Host and Windows XP Pro (32-bit) Guest. Error occurs almost straight away before the VB BIOS screen appears. The disk image boots okay when switched to IDE mode.

comment:2 Changed 6 years ago by seraphim

the bug still exists in 2.0.2 with debian etch kernel 2.6.18-6-686 host and windows guest.

comment:3 follow-up: ↓ 4 Changed 6 years ago by sandervl73

  • Summary changed from Raw vmdk does not work with SATA to Raw vmdk does not work with SATA -> fixed in 2.0.4

Thanks for reporting it. Just fixed it locally. Unfortunately you'll have to wait for the next version.

comment:4 in reply to: ↑ 3 Changed 6 years ago by loomy

Replying to sandervl73:

Thanks for reporting it. Just fixed it locally. Unfortunately you'll have to wait for the next version.

Is there an ETA on 2.0.4? :O

comment:5 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:6 Changed 5 years ago by vkov_tinsky

Raw vmdk + SATA still does not work:
Booting a WinXP SP2 (32-bit) guest with v2.0.4 (on both WinXP & Ubuntu 8.04 hosts) results in a crash (in vboxdd). Again, the issue does not appear when using IDE.
(see  http://forums.virtualbox.org/viewtopic.php?p=43020#43020)

comment:7 Changed 5 years ago by aeichner

Can you provide a core dump please? This is described here  http://www.virtualbox.org/wiki/Core_dump Please compress and make it available for download somewhere like for example  http://www.2shared.com or  http://www.rapidshare.com

Thank you.

comment:8 Changed 5 years ago by aeichner

  • Status changed from closed to reopened
  • Resolution fixed deleted

No need to create a core dump I was able to reproduce it. Can you try if the following command works around the crash: VBoxManage setextradata <VM name> VBoxInternal/Devices/ahci/0/Config/UseAsyncInterfaceIfAvailable 0

I'm really sorry for any inconveniences.

comment:9 Changed 5 years ago by vkov_tinsky

Setting UseAsyncInterfaceIfAvailable 0 does indeed stop the crash and the VM boots normally with SATA enabled. (I've only had time to test this with XP host+guest for now.)

comment:10 Changed 5 years ago by vkov_tinsky

Setting UseAsyncInterfaceIfAvailable=0 on Linux host (Xubuntu 8.04 32-bit) cures the crash also.

comment:11 Changed 5 years ago by vkov_tinsky

Sorry, forgot to ask: Does setting UseAsyncInterfaceIfAvailable=0 reduce performance and does it only affect SATA? (Theoretical question of course since VM boot isn't possible otherwise.)

Regards, VT

comment:12 Changed 5 years ago by aeichner

Yes only SATA is affected. Performance shouldn't be affected.

comment:13 Changed 5 years ago by vkov_tinsky

Apologies in advance since this is slightly off-topic: I get worse performance with SATA than IDE under WinXP host (see  http://forums.virtualbox.org/viewtopic.php?p=43470#43470). As far as I'm aware there's nothing wrong with my host XP installation so my question is whether a) This is normal or b) I should report this.

comment:14 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Please check version 2.0.6. The bugs should be fixed and the SATA performance should be improved.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use