VirtualBox

Opened 9 months ago

Closed 6 months ago

#21778 closed defect (fixed)

NatNetwork no longer supports VLANs => fixed in SVN/next 7.0.x maintenance

Reported by: paaguti-u Owned by:
Component: network/NAT Version: VirtualBox-7.0.10
Keywords: NatNetwork, VLAN Cc:
Guest type: all Host type: all

Description

VirtualBox 6.x or earlier supported VLANs over a NatNetwork. I was able to create parallel connections when I connected more than one VM to the NatNetwork. For example, supposing eth0 was connected to the NatNetwork to access the Internet, on Linux I was able to create a eth0.100 to communicate over VLAN 100 to another VM connected to the NatNetwork.

This is much more convenient (and close to real-world scenarios) than creating two interfaces, one connected to a NatNetwork and one connected to an internal network, which is my current "work-around" for this "bug".

Change History (3)

comment:1 by aeichner, 8 months ago

Can you attach a VBox.log of one of the affected VMs?

comment:2 by aeichner, 8 months ago

Summary: NatNetwork no longer supports VLANsNatNetwork no longer supports VLANs => fixed in SVN/next 7.0.x maintenance

Without any logs I assume that you are using the Virtio Network device, for which VLAN support was indeed broken. Will be fixed in the next 7.0.x maintenance release, thanks for the report!

comment:3 by galitsyn, 6 months ago

Resolution: fixed
Status: newclosed

Hi paaguti-u,

We just released a new version of VirtualBox today. This issue should be fixed there. Closing it. Please leave a comment if it is still actual for you. As usual, builds are available on Downloads page. Thank you for reporting.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use